Osmand~ rendering is incredibly slow part 2


#1

This is a follow on from this which was closed due to inactivity

Is anyone else experiencing major slowness in OsmAnd~ displaying map.

From startup it takes about 8 seconds to display the map tiles (I
hope I am using the right term), before that you just get an empty
map area.

Scrolling around or zooming out to show a wider area (more new
tiles) takes just as long at about 7 to 8 seconds per new tiles
you come to.

It makes OsmAnd~ very hard to use.

The version being used is 2.9.3

This is something I recall happening previously with the f-droid
specific version of OsmAnd

Since the last topic was locked

Yesterday I tried 3.1.5. This still had the rendering lag of about 3 seconds and would not cache the tiles so if you moved an area off screen and back again you had to wait for 3 seconds to render again

Today I have tried 3.1.6, rendering has increased to roughly 4-6 seconds now but it does look like tiles are being cached a bit better.

This is on Samsung Galaxy S4 running Lineage OS 14.1 (2018-08-17 / Android 7.1.2)


#2

As of 3.1.6 scrolling the map only rarely takes a couple seconds to load the new area, as opposed to always taking 3-5 seconds. However the lag when zooming is still present.
AOSP Extended on lenovo p2.


#3

I can see some improvements, not large (Mate9/Oreo), at the same time seeing it loading smoothly and fast on an “older” SD801/Marshmallow device…eh… ;(


#4

There shouldn’t be much differences between 3.1.5 and 3.1.6. I haven’t looked at the code diff but it should be rather small and not throw over the core rendering performance.

It would be interesting to know at which android version you are. There have been upstream reports at android 8 being slow.


#5

It slowed down for me at Android 8 which is expected from upstream.


#6

3 to 5 seconds is “a couple seconds”. So what did you really mean?


#7

Instead of loading for 3-5 seconds every time the map is scrolled, it now loads instantly most of the time and takes 1-2 seconds to load occasionally.


#8

This is on Samsung Galaxy S4 running Lineage OS 14.1 (2018-08-17 / Android 7.1.2)


#9

Update everyone, this time it’s good! :slight_smile:

Granted, I don’t feel it’s perfect and have not yet compared it to other devices, it’s working pretty good.


#10

Thanks for letting us know, I had missed that there’s a new version 3.2

It’s a good bit better. Scrolling around the map takes about 2 seconds to render now, it does seem that start up time is longer, taking up to 30 seconds to get from splash screen to maps


#11

You don’t have F-Droid installed and sync from time to time?


#12

I do, maybe it’s a setting in f-droid but in the versions for osmand 3.1.6 is listed as “suggested” I guess that might be why I was not notified. It happens frequently for this app.


#13

Some times developers treat it as BETA, hence won’t be suggested


#14

yeah, point 0 releases of osmand are considered betas. nobody had time to add the .1 and by the time I added 3.2.2 the index got stuck for 2 weeks. That’s why it took this long to promote it from beta to stable this time.