OsmAnd+ : Considerable Update Delay

I’ve noticed that the current version of OsmAnd+ on F-Droid is stuck at 3.8.5 (November 16, 2020). The current version at Google Play is 3.9.5 (February 3, 2021).

Can somebody other than the original developer build and maintain the package so that the most-current version can always be available here?

I’m sure the mice are spinning the wheels working on it. You could explore build issues with F-Droid Build Status or referenced site.

If I had to guess, the upstream developers have changed some things around and broken some spokes.

Build, sure. Maintain, IDK.

Osmand has a really complicated build setup, we welcome contributions there to help keep it building.

Whoomp! There it is. 3.9.4

Woo hoo! “Thank-you” to all of those who helped to get this update together and loaded!

  • even though the global lock-down puts a dent in my ability to use the program as I had during Pre-Pandemic Times :earth_africa: :grimacing: :mask: !

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Does anyone know if OsmAnd builds on fdroid are still being maintained or are there issues with that? The last OsmAnd release from September wasn’t released on fdroid until November, and releases since then haven’t appeared.

Osmand’s build process changes frequently, so can’t auto update. But someone just submitted a MR: Update OsmAnd to 4.1.9 (!10256) · Merge requests · F-Droid / Data · GitLab

1 Like

Osmand was a bit odd in how it showed up in F-Droid. Awhile back I was running v3.9.10. That was the last version shown when checking for updates (iow no updates available). However, when going to the entry itself I saw that there was some version 4s. Chose the latest one and it installed fine (so it wasn’t a signature change issue/reason). After that any new version 4 builds would show up as updates.
Latest version on F-Droid is 4.0.9, November 6 2021. Latest at the Osmand site is 4.1. As you (should) know, F-Droid builds things themselves so releases are usually delayed compared to their upstream.

Version 4.1.9 was just built on this morning’s build cycle:

https://monitor.f-droid.org/builds/log/net.osmand.plus/419#site-footer

I imagine it will show up as an update in the F-Droid app just in time for Christmas.

This is similar to a few other threads, but the Jan version of OsmAnd+ that exists on F-droid is hardly usable on Android 11/12+ wrt storage permissions

The version on the Play store seems to have fixed it.

Can someone help ?

Slow updates of OsmAnd at f-droid is a perennial issue. It is a beast to update, apparently.

It seems to get slower with every update, but they also keep adding features…

Work in progress: https://gitlab.com/fdroid/fdroiddata/-/merge_requests/11204

Long time f-droid user, first time trying to interact with dev/build infra.

Question: now that the PR is merged into master, how can I monitor progress building it and availability in release channels? A doc link would be most excellent.

&

1 Like

Look, it’s Version 4.2.4 (424) - Added on 2022-07-03.

https://f-droid.org/en/packages/net.osmand.plus/

The custom map location still doesn’t work in 4.2.4

Don’t know what it is.

If you mean “storage location”, go to Android Settings - Apps - Osmand - Permissions - Storage - grant ALL access

In the app go to Settings - Settings - Data Folder - Manual path: /storage/emulated/0/folderofchoice :wink: