Blank app icons

Hello Team F-Droid,

All app icons disappear in the F-Droid Android app (currently on version 1.13.1). I’m using OnePlus 8T running on Android 11 (OOS

Icons disappear from all tabs - Latest, Categories, Updates, Manage Installed Apps,…EVERYWHERE!

This problem was there on earlier builds too.

Force stopping the app and deleting cache DOESN’T help. Deleting app data helps, but then one has to manually add all the repositories again and configure the Settings again


This problem has been reported earlier too:

Please fix this.

That thread you linked also explains the solution :slight_smile: You probably just disabled loading images on the settings screen.

No, I haven’t.

The problem, as far as I can tell, happens when we try to add a repository.

Today, I added the NewPipe repository, and after that the icons disappeared. Same thing happened earlier when I added Bromite repository.

This is just my observation. May be the icons could also be disappearing randomly.

Could you please take a (long) screenshot of the settings screen?

1 Like

Here it is:

1 Like

Thanks. Hmm, and you are on WiFi, I guess? I don’t have the problem on my device. When adding repos, the icons are displayed correctly. Maybe a log output could help but I do not know if F-Droid logs image loading errors. Sorry, I can’t help here.

1 Like

Yes, I am connected to WiFi.

I have added only 2 repositories, and I noticed it both times. So it is just a possibility.

But the fact that the problem isn’t resolved with a force stop and deleting cache is unexplained.

Hopefully developers would resolve this soon.

Thanks for your time and help.


Try latest alpha too, try with mobile data slider all the way to the right too.

The problem happens while connected to Wifi, so if turning the mobile data slider to the right helps, it is something that the app developers should sort out.

I’m not a regular user of F-Droid, so it isn’t too much inconvenience for me, atleast at this point.

There were some fixes related to that, iirc, hence testing with 1.14-alpha0 or alpha2 when that’s out (next week?!)

Icons (and screenshots) take data. I’d be happier if they never displayed, unless I asked for them.

Everyone has their preferences, and it is varied. A community is not just one person.

Thanks a lot @Licaon_Kter, I had the exact same issue as @TheMystic after upgrading from outdated ver 1.12 to 1.13.1. Installing 1.14.alpha0 apparently fixed this.

A small heads up:
TL;DR > check storage permission for F-Droid when clearing app data.
I don’t know if this related, some time ago with an older version of F-Droid, I had this same issue and when I enabled the storage permission (after I found that it was disabled by clearing F-Droid app data), icons and screenshots appeared again; since then this episode stuck with me.
When I upgraded this time to ver 1.13.1 and icons disappeared, I tried clearing the data, but didn’t help. Then when I re-enabled storage permission it helped but only for icons at top of initial page, scrolling down the other icons remained blank. Also app screenshots were blank.

I am experiencing exactly the same issue. Some app icons are missing when searching/browsing apps in F-Droid. Not all but just a few (e.g. NewPipe, BombusMod, Traccar Client, Waistline). I tried everything, clearing cache/data, updating to 1.14.alpha2, enabling storage permission, rebooting, disabling/enabling WIFI… I don’t know if those icons are actually just missing from the repo or if it’s not downloading them.
This had been a recurring problem with F-Droid, but generaly clearing cache/data does the trick.

Just noticed the same for Conversations/Quicksy, both Client and website, so it must be something new.

I think this could be an issue that happens while generating the repo on the server. The index file doesn’t include the icon key for some apps, even though they should have one.

E.g. when checking for Quicksy in index-v1.jar, it doesn’t include this property, which might explain why only some apps don’t have icons (the server software doesn’t extract it from the app for some reason).

It also happens in my own repo where Notality has an icon, but “Rock It!” does not. The second app was added a bit later, but as one can see from this commit only the icons of one app (Notality) were extracted, but not those of the other. I’m not really sure why this would happen as both apps are really similar (both use Flutter, both use a PNG icon etc).

In my case, none of the apps have any icons. You can see that in the screenshots.

Icons are missing everywhere, in everything.

In 1.14-alpha3… clean app DATA, resetup repos, set Wi-Fi and mobile data to the right or the middle, pull-to-refresh index?

i too have same problem. tried everything said above but doesnt work at all.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.