What's the installation procedure for F-Droid Priviledged Extension?

Hi everyone,

I’ve been having some troubles trying to install the f-droid privileged extension on my Pixel XL running Android 9.0. When I try to update or install applications using the privileged extension, I get an error saying “Error installing package: the privileged permissions have not been granted to the extension!”.

Here are the steps I took to install F-droid and friends:

  1. Installed the standard f-droid apk from f-droid.org
  2. Downloaded and installed “F-Droid privileged extension” application from within f-droid itself (https://f-droid.org/en/packages/org.fdroid.fdroid.privileged/)
  3. Flashed the ota zip from TWRP (https://f-droid.org/repo/org.fdroid.fdroid.privileged.ota_2090.zip)

Is this the right order? I’ve tried some other permutations but haven’t had any luck yet. If anyone could provide any suggestions or let me know what they have tried, I would love to hear it.

I miss the functionality to install without having to click through each update/installation - the only time I’ve ever actually had this working was when I ran LineageOS-microG with f-droid privileged preinstalled

I’m using Magisk and the corresponding module (aka no TWRP), can you try that?

Thanks for the suggestion, but I’d like to avoid using Magisk here. I am running LineageOS and one of the LOS developers told me in IRC that updating LOS with Magisk installed can brick /system. Ever since then, I’ve been using lineageOS’s su addon to prevent further breakage

I feel like this possible without Magisk and am pretty curious to how one is supposed to install the extension

Check the bug reports, there are some issues flashing on some 9.0 ROMs https://gitlab.com/fdroid/privileged-extension/issues

But really, if you’re using LineageOS, then just flash Lineage-for-MicroG, and its built-in.

Thanks - I do feel like I’m running into this bug:

Good to know that it’s not just me

I might consider flashing LOS-for-microG but for the time being I’m going to try to get this working on LOS - I’d rather not migrate or flash a new ROM. I have having this problem on stock also

Mastodon