What is the Gitlab Repo URL to type in the FDroid client?


#1

Hi people!
I’m sorry to ask a similar question as before, but I still haven’t been able to solve the problem.

On the one hand: I can create a repository with Repomaker and add my Gitlab account as storage. Then I can type in my F-Droid client a repo URL similar to
https://repomaker.grobox.de/repos/user_x/repo_y/repo
where x and y are some numbers.

On the other hand: I can create a repository locally and upload it to Gitlab directly: Either directly by just pushing all the contents of the local directory /path/to/fdroid/repo or by running fdroid nightly after setting servergitmirrors and identity_file in /path/to/fdroid/config.py. But then what do I type in the F-Droid Client? Because I tried
https ://gitlab.com/path/to/repo/tree/master/fdroid/repo
https ://gitlab.com/path/to/repo
https ://gitlab.com/path/to/repo
and none of these work.
The last two cause the Java exception:
java.io.FileNotFoundException: https ://gitlab.com/path/to/repo/index-v1.jar
and the first one the Java exception:
java.util.zip.ZipException: error in opening zip file

I tried all of this with this docker image as well as with a local fdroidserver.

Thank you for listening :-))


#2

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.