Host f-droid repository on Gitlab WITHOUT repomaker?

Hello people! How are you?

So I was gonna try to upload my local fdroid repository to gitlab and then access it from the FDroid client. But the furthest I got was an error message of the kind of
“Could not open zip file index-v1.jar”
which I could only see through ADB because FDroid itself very uninformatively says “Error getting index file”.

I tried the tool repomaker and if I configure that same gitlab repository to be my storage there, then it works perfectly. Until repomaker itself crashes or whatever, because apparently this is still an unstable version.

Is it possible to use raw gitlab to store my FDroid repo or not?

You don’t need Repomaker at all, its built into fdroidserver. Read examples/ included with fdroidserver.

Here’s an example that was generated using the fdroid nightly command:

Thanks for the reply! But I can’t add your example repository. It’s asking for a username+password.

If I use repomaker, it gives me a URL to type in the FDroid client, and it works immediately. For example
https ://“number1”/repo_“number2”/repo
But if I use this fdroid nightly command or fdroid deploy even if I configure servergitmirrors and identity_file, I can’t access this repo from the client, no matter which URL I try.
I tried
https ://“username”/“reponame”
https ://“username”/“reponame”/fdroid/repo
https ://“username”/“reponame”/master/fdroid/repo/

I set
servergitmirrors = ‘“username”/“reponame”

I’d be thankful for any suggestions!

You can see example Github/Gitlab URLs listed under here


Or by getting the URL from the QR Code on any fdroid nightly repo:

Ok thanks @hans ; I figured out what my problem was:
The Gitlab repo I set up for use with fdroid was private! That’s why the file index-v1.jar that was downloaded wasn’t actually a jar file but a html file saying that I have to sign in :smile:
And the right github/gitlab url to use are
https://gitlab. com/path/to/repo/raw/master/fdroid/repo

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.