Updating apps fails with privileged extension

#1

F-Droid has 7 updates for apps. When I touch go, they seem to be updating and then I get a warning saying update failed. It says:
Error installing DuckDuckGo Privacy Browser
The privileged permission have not been granted to the extension!
Please create a bug report!

Is there a way to fix this please?

0 Likes

#2

Sounds like the same issue as described in this topic:

Did you install the privileged extension? If so get rid of it and you should be fine.

0 Likes

#3

Thanks for the reply. I didn’t think I installed the privilege extension. I came to f-droid in a roundabout fashion and I wonder if that has messed things up. I had installed Ubuntu Touch but didn’t enjoy using it. So installed LineageOS over the top and then installed F-Droid on top of that so the phone might be a bit flaky!
Is there anyway of telling whether the phone has the privilege extension installed please?

0 Likes

#4

How did you install F-Droid?

0 Likes

#5

I downloaded a zip to the phone and installed it that way.

0 Likes

#6

No, how did you install the F-Droid client, the APK ?

The ZIP is something else… is that privileged extension… also, HOW did you install that exactly?

FYI, using the Magisk module with the privileged thing works nicely…no flashing needed (except to install Magisk as usual)

0 Likes

#7

I am doing some reading at the moment trying to understand the system. As far as I remember I downloaded the zip file directly to my phone. Unzipped and installed - for f-droid. I am about to have a go at installing Magisk. Thanks

0 Likes

#8

Where did you get that zip file?
Try uninstalling the app and install the official apk file from https://f-droid.org/ instead.

0 Likes

#9

Hi
I uninstalled the app and reinstalled. It has updated some of the apps and others it is saying I need to be rooted. So I am going to close this topic and head off to LineageOS to reinstalled that with a rooted phone… unless someone can tell me how to change my phone to rooted without reinstalling everything! Thanks for any help.

0 Likes

#10

What does “others” mean? Those apps need a rooted device to function or what?

0 Likes

#11

@ gucu : “installing” ZIP is very different, You don’t need to unzip it. You need to install it in a Custom Recovery, e.g. TWRP.

0 Likes

#12

Some examples.
App is Simple File Manager - when I try to upgrade it says The privileged permissions have not been granted to the extension!
F-Droid update - error installing F-Droid (same as above)
YouVersion Bible App - The apk is split. Choose root or privileged installation method

Re-installing F-Droid to record what I do:
Click on Download F-Droid
Downloaded apk
Install F-Droid
Open F-Droid
Updating repositories
Now running updates
First update is F-Droid - bizarre because I just downloaded the latest version and it comes up with the error privileged permissions have not been granted.

0 Likes

#13

The APK on the f-droid.org page is an older “stable” version, so yes it will (try to) update to latest 1.5.1 on index update.

0 Likes

#14

@gucu Pls say again, what is your status? How did you install? What did you install?

0 Likes

#15

I downloaded an apk file and clicked on it to install.

0 Likes

#16

F-Droid…how did you install F-Droid and the extension?

0 Likes

#17

@ gucu , the Privileged Extension must be installed as the system app. This is done mostly from inside a custom recovery, e.g. https://www.youtube.com/results?search_query=install+zip+TWRP

0 Likes

Mastodon