Unable to get Apps and Update F-Droid


#1

I’ve installed F-Droid directly from fdroid.org
The version I got there is 1.0.2. I’m pretty sure there’s a newer version which may be the reason no apps etc show for downloading and installing. After installing and open the app, a pop up notification of “error index files”. It never shows again. Only upon installing. How do I get the latest version of F-Droid? Is this why I’m getting the above error and seeing no apps to download?

I’ve uninstalled, downloaded again, and reinstalled three times, but nothing different.

I’m using Pixel 2 XL using the latest version of Oreo. I’m not sure if this helps. I gave the app permission as well.

Looks like after toggling the repositories for F-Droid and The Guardian Project several times, the apps have now populated.


#2

There is a bug preventing the current index from being parsed. The fix is just waiting to be deployed:


#3

Funny thing is: If old index format is enforced in F-Droid expert settings, it works


#4

I’ll still sometimes get the error w/ old index version option. Maybe some of my configured repos (I’ve 18, cuz… y not? :stuck_out_tongue_winking_eye:) only use the new version? 🤷


#5

the same thing happens to me, and no one was able to help me. I must say I’m not a geek and don’t understand if you give very complicated things to do…sorry!

my problem is still there: impossible to use F-droid, to see any app, to download anything…


#6

I figured it out on my own. Go to Settings > Repositories > F-Droid and toggle the switch next to it. I kept toggling that switch sbd and the one next to F-Droid Archive and finally the apps appeared. Hope this helps.


#7

sorry, but there is no possibility to switch anything on my phone in that place… I’m french and have a french smart phone “ECHO”, maybe it’s different from yours…
thanks anyway!


#8

You have to go to Settings in the F-Droid app, not to the system settings.


#9

That’s the settings of the F-Droid app and not your phone settings. Apologize that it wasn’t clear.


#10

Thanks, I tried to do that in F-droid, but it still doesn’t work, I get the message “error getting index file”…


#11

This should be fixed some days ago.


#12

Just be clear, the fix was for F-Droid server, correct? So each instance would have to deploy latest version? 'Cuz I myself am still seeing that error (a lot), but I’ve multiple repos configured.


#13

each repo needs to update their copy of fdroidserver to fix this bug in their repo


Known Repositories
#14

It still isn’t fixed right? Made an account just for this.


#15

This is fixed in fdroidserver and on https://f-droid.org. For other repos, the people managing them need to update to fdroidserver v1.0.4 or higher to get the fix.