This Android ROM does not support ACTION_INSTALL_PACKAGE

Hi there, my apologies if I say something stupid, this is my first post.

I’ve been able to run Fdroid smoothly for just about every other phone, but this Aquos A205sh is giving me a lot of trouble. I am able to install APKs just fine, and even able to install from the Aurora store… but for some reason, JUST the Fdroid client gives me this error when updating or installing packages.

Ive checked my system apps and android package manager IS in there, but for some reason the app doesnt recognise ACTION_iNSTALL_PACKAGE no matter what I do. I dont mind installing from Aurora but if possible I’d REALLY want Fdroid for the FOSS experience.

Kind rergards,

Seems the intent (action/task) is not supported for some reason.

Meanwhile, can you check the application settings under system settings and see if allowed from untrusted source / allow F-Droid to install is turned on?
Go to system based settings. Then apps/applications. Find F-Droid and open its info/app info. Check for install unknown apps or similar. Turn it on. Then try once.

Hi there, thank you for the reply.
Thank you for pinpointing out that the intent is not supported. Is there any way to add support to the revoked settings? I also have approved for downloading unknown apps on F-droid, but to no avail… still gives me that same error. I do not know why Aurora store works fine but this does not :confused: Any tips or workarounds would be much appreciated.


Which F-Droid Client version do you see in About? Latest 1.19?

Which Android version is that?

Can you enable Expert and check the “do not use Session Installer” to ON at the end and then retry?

Hi there Licaon, my apologies for the lack of information regarding android/f-droid versions. currently the version of this phone (sharp aquos A205sh) is android 10, and the f-droid client is 1.17.0. However I cannot update the client due to the strange restriction ive encountered. I have also enabled expert settings, however I cannot seem to find the option for do not use Session Installer. is it a feature in 1.19? Please let me know.


Yes, but since you can install APKs from outside F-Droid, you can update to latest 1.20-alpha: and retest, yes? :slight_smile:

Hi Licaon, thank you so much for the link, ill do that immediately and report back with results! :smile:


Update - unfortunately disabling the session installer doesn’t do the trick, it gives me the exact same error :frowning: I have also tried force old index but that didn’t seem do much either.

Can you try and install via ADB the new or even earlier F-Droid versions? Try this guide for that:
After that reboot once (phone) and then try to install something from F-Droid again.

note that they already did that… the issue is that F-Droid can’t install BUT other apps (system) can.

Yup I know. I just edited my post. I am thinking, that for some reason that F-Droid version they have is causing it, and if installing newer FD via ADB can help diagnose more.

Update: Mostly the request installer intent would be missing for higher SDKs, something like >

 <uses-permission android:name="android.permission.REQUEST_INSTALL_PACKAGES" />

Let’s try older versions then…


any of them work?

you tried before disabling Session installer too?

1.17 does not have Session Installer

1.20 has

ah, I have used ADB install as a way to transfer the F-droid files.

Yes, I have tried installing the 1.20 alpha version you linked me, but it still didnt do the install properly unfortunately :frowning: ill try installing the older versions to see if they fix the problem

Aurora store works fine

I’m not an expert at either, and Android documentation says this won’t work, but interestingly the Aurora store has a

        tools:ignore="ProtectedPermissions" />

in their manifest, which is not present in the F-Droid manifest. If you have the patience and capability, you might want to compile a F-Droid version with that permission added to the manifest.

1 Like

Exactly. This is what I told earlier. F-Droid does not have that and seems some phone have those in their system.

hi there everyone, i have tried all older versions and unfortunately it seems that this sharp aquos flipphone really is unable to install the apps on the store. :frowning: ill stick to installing from Aurora for now, i think it is indeed the ignore protect permissions thing in manifest thats making the aurora store ‘force’ it to install apps on the phone. no clue as to why they made it permission protected on this phone though… maybe its a thing for japanese flip phones?

also another update- izzyondroid works with installing apps within the app too, not just aurora (decided to download it and it also worked)

which Aurora version? 4.4.3?