Some app updates fail to install and force f-droid to close


#1

Hello,
as stated in the topic, i started recently to have this problem.
Some app updates (torrent client, kiss launcher, odyssey) force F-droid to close and don’t install.
Another app recently added (paper launch) has the same behavior.
In addition, if i manually download the apk files when i try to access the download folder, file manager suddenly closes. I have to manually remove the apk files by connecting device to PC and using PC file manager.

I already reported this on the following thread Several apps caused bootloop on Cm 12.1 but since i don’t have CM and in my case it’s not a bootloop issue i preferred to open a new topic.
I have Android 5.0.2.

Thanks


#2

Something is very wrong with your Android system. Try doing factory reset
and/or change ROM. Don’t forget to backup.


#3

Uhmmm… I’m not a developer, so i can’t argue, but frankly it’s hard in my opinion to believe that if 3 of the dozens of apps installed on my device don’t update, then there’s something wrong on the device…
Those 3 apps updated flawlessy until latest releases, could It Be possible that something changed in latest build process?


#4

Hello,
Here i am again with some useful information, courtesy of Odyssey music player developer.
There seems to be a bug with android build tools:

https://issuetracker.google.com/issues/64434571

He has then built the apk with build tools 27.0.1 and now It works.

Thanks


#5

The problem is somewhat similar to the one in thread you are referring to. I have also experienced crashes when file manager (or a backup application) was trying to access the .apk. The fact that you were not able to install any of those apps is most likely saved you from the boot loop.

The only thing that does not fit is that your list of problematic apps is different. Could you try any of the apps listed here: https://gitlab.com/fdroid/fdroiddata/issues/979? Power Ampache 1.09.39 does not cause a boot loop so you might start with that one if you do not want to risk it.

I have tried factory reset and also full wipe and re-flash but it did not helped.


#6

Hello, i tried with Power ampache and Can confirm that the behavior it’s the same of my mentioned apps.


#7

Just an update (and a confirmation): even Torrent Client developer compiled his app with build tools 27.0.1 and now the app installs on my device. It seems that the solution have been found.


#8

I see that this is fixed with build tools.
But for the protocol this remains to be a vulnerability. The build tools
emerged to be an exploit and updating it just “tells” build tool “don’t
touch this weakness” :slight_smile:


#10

think you could go, before an hard reset, in settings/app/app which crash or restart/ and try to delete the cache


#11

Deleting caches does not help. I’ve tried to delete app a dalvik caches.


#12