RepoMaker does not upload files

I have added my first repo in RepoMaker. Set up the git storage with ssh key is done. But RepoMaker isn’t uploading the files ?
In ‘share’ option is only the button for adding the storage available.

How can I upload / publish the f-droid repo ?

I think the issue is, that I don’t have an LogIn screem as shown here when I’m starting RM

I think the issue is this. When I’m starting the web interface with this command
ich@ich:~$ repomaker-server & repomaker-tasks & xdg-open
I’m getting this mnessages:
repomaker-tasks: command not found.
repomaker-server: command not found…

OK, seems I’m the only one here which is using, or better trying to use RepoMaker. Sad. Seems to be a nice tool, but …

The source repo has some issues mentioning this is in need of maintenance, yes

What’s your use case here? Deploying a repo?

Yes, I want create my own f-droid repo

I never used repomaker, I don’t host a repo, but afaik you don’t need all that.

Just fdroidserver and host the files.

@Izzy have any quick info at hand?

I have tried all tutorials from Izzy webpages. None is working.

The command line procedure with fdroidserver is working. But if there is a nice GUI for that, I think it should work.

Whut? My tuts don’t work? First time I hear that. But with the second paragraph you write

Well, that’s what my tuts are about? Ah, I guess you refer to the article on Repomaker itself. That was written quite a while ago; as Repomaker is currently unmaintained I have no idea if it still works.

Maybe you give Setting up a simple binary F-Droid repo a look. It also mentions a Docker solution (created by @TheLastProject), where you’d just need to drop-in your APKs and the setup takes care for the rest. Your GUI then could be the file explorer :wink:

OK, as I have written before, I have created a repo with this. But how can I add screenshots ?? For this action I can’t find any tutorial

And an other question: Which icon is shown in app overview or as app icon ? ic-launcher or ic_launcher_foreground or ic-launcher ?
Because 3 of my apps are show the right icon and 3 don’t show any icon

Ah – that’s correct, that was planned as the next part of the series. OK, a short “how-to” on that as I’m unlikely to write up that next part within the next few days:

Placing graphics and support for multiple languages rawly follows the structures of Fastlane, as described in my Fastlane Cheat Sheet – with the difference that it’s split up a bit (at least the way I use it with my repo, to avoid duplication):

  • text files (short_description.txt, full_description.txt etc.) are placed into metadata/<packageName>/<locale> – e.g. metadata/, with en-US being mandatory
  • icon and featureGraphic go into repo/<packageName>/<locale>
  • screenshots are stored in repo/<packageName>/<locale>/phoneScreenshots (and optionally the corresponding directories for other sizes, as described by the Cheat-Sheet – though I don’t use those with my repo)

From those places they are picked up automatically when you build an index. If you want to use those text files, you must make sure that the corresponding parts are removed from the app’s YAML file, which otherwise takes precedence (e.g. for full_description.txt to be picked up, the *.yaml must NOT have a Description: set).

As for the icons: I’m not sure which one is picked up (if you place an icon.png in the fastlane structure as described above, that should be the one used IMHO). I just know the only supported formats are PNG and maybe JPG (unless something changed since I’ve learned that), so if you e.g. used WEBP that might be the reason it’s ignored.

1 Like

sorry, but it isn’t working. pls see attached pics
f-droid client- no pic, no description:

Git repo:

local repo storage:

what’s wrong ??

Please read my previous post again: where shall the pictures go? You’ve placed them inside metadata, according to your 3rd screenshot. I wrote they should go to repo/<packageName>/<locale>/phoneScreenshots/* (for the screenshots) resp. repo/<packageName>/<locale>/ for icon/featureGraphic. If you do as I described, it should work :wink: It does here.

PS: Let me explain the logic, maybe it’s easier to remember then.

  • All that’s distributed must be inside repo/.
  • All from inside metadata/ goes straight into the index, which is created inside repo/.
  • As pictures cannot be embedded to the index, they must be placed inside repo/ themselves.
  • look where the icons are placed when extracted from the APK files: inside repo/.

Hence the division: placing text files into metadata/ so they can be parsed for creating the index – and placing pictures into repo/ so they can be distributed directly.

I was going as shown here

Ok, I will try it the other way. Will keep you updarex

That’s why I wrote, quote:

(emphasis added). Fastlane structure as in the cheat-sheet is for placing it in the app’s repo. F-Droid’s internal structures rawly resemble that, but with a slight deviation (as described).

Best luck – and yes, please let us know!

i think the problem is that there are 2 repo folders and I don’t know which repo folder I have to use.

I have placed metadata and all related files in /repo/repo folder. Still no working

EDIT: whenplacing the ‘’ folder direct in repo/repo same bad result

can someone post the folder structure of a working repo please ??

I have no idea what you did now, as the screenshot only shows part of it. But that the icon folders are on the same level as the metadata one looks plainly wrong. Did you place a metadata folder inside repo/? It doesn’t belong there. The structure should look like this:

  +- ...
 +- com.foobar
    +- en-US
       +- short_description.txt
       +- full_description.txt
 +- com.example
    +- en-US
       +- short_description.txt
       +- full_description.txt
 +- com.foobar
    +- en-US
       +- phoneScreenshots
       +- icon.png
       +- featureGraphic.png
 +- icons
 +- ...

which repo ?? there are 2 repo folders. please see screenshots

that’s how you have written and it’s still not working

That structure looks correct to me and should work – provided your “repo root” is /media/ich/data/repo and not /media/ich/data, and you run the fdroid commands from inside /media/ich/data/repo. The only thing I wonder is that I see a there – which means you’re using a pretty old version of fdroidserver (recent ones have a config.yml).

I’m using fdroidserver on Mint 18.3 and yes I have heart that it’s an old version.

How can I update to latest version on Mint or ubuntu ?
fdroidserver Version (1.1.10-1~bionic).

EDIT: I have tried on Ubuntu 21 with
fdroidserver version (2.1-1~impish) and config.yml

But nothing changed, Still no description, icon, screenshot

The command ‘fdroid deploy’ is OK or not ?

here the latest log.txt

I have made a complete new restart. New folder, new fdroid init, new fdroid update and new fdroid deploy… but still no change. :(((((