RepoMaker does not upload files

Indeed: Mint 21 is already being prepared. And there I thought I was behind. Mint 18 is no longer in support, AFAIK Mint 19 ran out of support last spring…

Following the article? But I have no idea if that still works on such an old version.

Um, what? Maybe all the time you just forgot to run fdroid update? fdroid deploy is for syncing the stuff up to your server. It won’t do a thing if there was no update run before (at least there won’t be a new index and thus no client would know to check for the screenshots etc).

Then I’m out of ideas, sorry. These steps sound correct – and provided your structure is correct, should lead to the intended result. In case we’re looking at the wrong tree, you could open the index-v1.json e.g. in a web browser and search (Ctrl-F / Strg-F) for one of the screenshot’s file names. If you find it there, all went well but your client looks at the wrong place (or you sync against something else).

puh… after a new start with totally fresh files it is working now. When I understand it right, I can add the app info in the related .yml file. No need for the .txt files, right ?

And many thx for your help !!!

EDIT: one more question. is it possible to create a default .yml as template for all new .,yml files. So I don’t need to add always developer / Source/ webpage and so on

yup, those are not used anymore


1 Like

Call it template.yml and place it in the repo root. It will then be copied to metadata/<packageName>.yml so you can fill in the gaps.

1 Like

Hello. I’ve already tried everything. I did the same


And it doesn’t display the icon for me (it’s empty) Maybe you need to do something in the repoker in the console after adding the icon?

I’ve tried deleting the app and re-downloading it - just an empty icon.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.