OsmAnd+ crashes every time I try to start it

Hi and thx to all f-droiders!

This is my first post even I’ve been using F-Droid for quite a long time. Don’t know if this should go to Github page. If so, please let me know.

Let’s get into business:

Sorry if I can’t tell the events for sure, because it’s happening a while now and I’ve tried so many things that I don’t remember the specific order of events and everything I’ve tried.

I’ve been using and updating OsmAnd~ / OsmAnd+ for quite sometime without any problem I can remember. I think it all started when I had 4.3.5 (2023-01-01) version installed (which is the suggested version) and I saw later that 4.3.8 (2023-01-26) version was avaliable, so I installed it. I think it was then when got an unknown installation error, so I went back to 4.3.5. Since then, every version I install (from 4.3.3 to 4.3.8), if installed without any error, starts and after a few seconds closes (I got to see some error messages I couldn’t reproduce / remember, but I saw once one saying it was reverting rendering engine to version 1 - I guess it meant from OpenGL v2).

For what I’ve seen in forums on the Internet, OsmAnd+ seems to have switched to OpenGL v2. I’ve tried several changes in Developer options such as switching Graphic controller preferences from Default to System graphic controller for OsmAnd+, Force MSAA 4x (both true and false) and Disable hardware overlapping (I guess, my options are in Spanish) but have made no difference.

I managed to install OsmAnd 4.2.7 free version (limited to seven downloads within the app) following the instructions explained in Install guide for OsmAnd~ (OsmAnd+) (When installation fails using the F-droid client) (thanks a lot @seasonshu! :+1:) and 4.2 free version works without any error.

I remember seen some webpage explaining how to debug graphics using adb but I can’t find it now.

Any ideas/suggestions?

Thx in advance.

I use a Samsumg Galaxy S4 (GT-i9505) with LineageOS 18.1 (always updated to the last available OS version).

1 Like

And there’s a setting in Osmand: Settings - Osmand Settings - Rendering Engine → toggle that to version 1 I guess, if you get a chance…

Try to install an older version, 4.2.x (enable Archive repo in F-Droid) and then upgrade to 4.3.3 maybe you can reach that setting.


Thanks a lot, @Licaon_Kter! It worked like a charm.

Uninstalled both OsmAnd and OsmAnd+ versions, enabled F-Droid Archive repository and installed OsmAnd+ 4.2.7 from F-Droid. Enabled OsmAndAdd-onsDeveloper options and checked that OpenGL v1 was used (don’t remember the name, but it’s quite obvious and it’s at the beginning).

It worked without any problem, so I upgraded to OsmAnd 4.3.5 (suggested version) and I can’t find any obvious OpenGL related option in Developer options Add-on, but the program didn’t close and I could download as many maps and files as I needed.

Once more, thx a lot!

Don’t remember how it was in 4.3.5 but in 4.3.8 it’s not there but in main settings as said above.

Do update to 4.3.8 and test :slight_smile:

Hi, @Licaon_Kter!

I updated to Osmand+ 4.3.8 without any problem, so I felt bold :nerd_face: and changed the OpenGL option to version 2 despite the program warns it’s preferrable to use v1 with old devices (such as mine). Showed a Loading data message and after it finished the program crashed. Tried to downgrade to 4.3.5 but got and Unknown installation error, so I had to uninstall OsMand+ and apply the solution. :smiling_face:

heh so it’s clear you can update but keep it in v1

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.