No Repo download/update with Android below 6

The F-droid app (and Droidify, Gdroid, Foxydoid) don’t fetch the F-droid repo on my Android 5.1 and 4.2 devices. They did a month ago.

Error Message:

Yes, known Lets Encrypt certificates issue, do this: Let’s Encrypt ISRG Root X1 and Privacy Browser – Stoutner

In F-Droid Client makes sure you have mirrors enabled (Settings, Repositories, F-Droid)

@Licaon_Kter

Thank you for your reply. Sadly the F-Droid verion 1.15.6 for Android 5.1 has no mirror setting.

I downloaded the certificate: https://letsencrypt.org/certs/isrgrootx1.pem.txt according to the link you posted, installed it, and now it works.

Many users of old devices will not figure this out, maybe a solution for them could be found.

Added this info to the docs: Add cert info to Running_on_old_Android_versions (635e71df) · Commits · F-Droid / Website · GitLab

There’s not much we can do about that.

1 Like

Maybe add a “show apps for Android version” setting to the F;droid app where you enter the version and see suitable apps. Else finding apps for older devices is extremely cumbersome. Installing them via browser isn’t the big problem, finding them is.
Often old devices can still be used as music players, photo albums and as toys for kids and need not be dumped.

we already do that, all that you see is compatible with your device

*but many old apps might be Archived… the docs explain this: Running on old Android versions | F-Droid - Free and Open Source Android App Repository?