New F Droid Driver, lost and need directions

Hello,
I am New to F Droid after getting a new phone and looking for a way to use my calendar & contacts without google because i’m sick & tired of having google’s hands into every piece of tech I own except my toothbrush,

I got as far as downloading the F Droid and then trying to download some basic apps e.g. contacts, k9 mail, new browser; but when I click the Install button on any of them, it shows a loading bar saying: waiting to start download, and then it ends, and then shows a message: not installed.

I’m lost, don’t know how this all works, if it’s even safe, but am just searching for almost ANY other option except Big Tech Google.

A finger pointing right or left, or just anything helps.

BTW, the phone i am using is DuraForce Pro 2, Kyocera.
I’m working on getting a galaxy maybe next month.

1 Like

What Android version? Are you asked to give F-Droid permissions to install?

1 Like

Hello,
Great of you to reply.

I’m not sure.
When I go to ‘About Phone’ it says software version: 4.207VZ.
software info: 9

And it did when I installed the F Droid, but not when I try to download an app from F Droid like the ones in my first comment.

When you installed F-Droid it asked for the permission for that other app, browser or file manager.

It should ask FOR F-Droid this permission now.

1 Like

For example:

I just went to my F Droid app, clicked it.

It opens up that screen.

Then I go to where it says ‘categories’ at the bottom, clicked it.

It opens up that screen.

Then I scroll down to where it says ‘contacts’ in the ‘phone & SMS’ section, clicked it.

It opens up that screen and reads ‘simple contacts by Tibor Kaputa’ and right below it there is an ‘INSTALL’ button, so I click it.

It shows a ‘loading’ bar then followed by a ‘NOT INSTALLED’ message at the bottom.

By the way, now it won’t even show me any ‘categories’ or ‘latest’ or ‘updates’.

I wonder if google is somehow blocking my F Droid app from letting me download anything through a “glitch” rolling my eyes.

Pull down on these screens to reload the index

1 Like

When I do it says:
Error getting F-Droid index file :arrow_right: Ran out of mirrors

I don’t know what a mirror is.

It’s a server mirror, anyway…this sounds like networking issues, is this on Wi-Fi or mobile data? Can you try both?

1 Like

mmmm.

Uhm, I am using my own mobile data, and have not tried WiFi; it is not available to me at my current location.

I will go to another location here shortly and retry using wifi.

I see these errors sometimes, on WiFi, and assumed it was server issues, because my network is otherwise working OK. Eventually f-droid updates work too.

1 Like

Just got back from using WiFi at a local Panera and it still has the same message I posted earlier.

Should I just give up and use google al over again for EVERYTHING on my phone, seeing as how I’m new to this F Droid program and it’s apps, and almost everything phone related.
:man_shrugging: :man_shrugging: :man_shrugging: :man_shrugging: :man_shrugging:

Something might block its network access then.

Can you get a logcat? (USB cable& ADB on PC or maybe you have root?)

1 Like
  1. I agree that is happening.

  2. what is logcat.
    I know what this is now.

  3. what is ADB/root.
    I know what this also is now. But do I really need to do all this to use the F Droid, I mean I went from trying to get freedom on certain functions of my phone to having to root my systemless root phone so I can superuser it, just to use the F Droid program and its basic contact and calendar apps that are free of google.

  4. I have the Phone USB cable.

Use a freedom loving search engine, maybe DuckDuckGo or Qwant, search for Android logcat maybe on XDA forum.

It depends on operating system and such.

1 Like

Everything I search says I need to use Google play to install.

I thought that was the whole point of downloading F Droid on my phone: To NOT have to use Google play to download apps​:thinking::thinking::thinking::thinking:.

What everything? Says what? Where? Please be more specific…

1 Like

Lucky for you there’s no LineageOS for your device or you’d be headed down the alternative ROM install path. Rooting isn’t necessary.

1 Like

https://apkpure.com/logcat-view-log-for-android/com.kibou.logcat

Those are the first 2 that I ran into.
But everything else like browsers, email apps, ADB, or just miscellaneous programs, that I am learning about, to use to be able to carry out functions on my phone almost all say to either use F Droid to download or Google play.
Since my F Droid keeps saying all the error messages I wrote above, what other option do I have but Google Play.

I was trying to keep google play out of my new phone but I guess that idea was just pissing in the ocean because this F Droid thing isn’t working out; without me first having to download apps, to use it, from google play.

It’s so weird though because the first day after downloading it, I was able to see all kinds of apps, sections, updates, and other stuff; then literally over night they are all gone, plus those error messages.

uhm, ok.

So what other options am I missing.