How to keep Mull browser updated?


I’m struggling to keep Mull browser up to date since months.

The problem is, using F-Droid client or eg. Droid-ify, with the DivestOS repo, everytime an update of Mull is available, I cannot install it, it fails because the signature isn’t correct. I first have to uninstall the actual version, do a fresh install from F-Droid, and most cumbersome part, add-ons, bookmarks and any other settings gone of course. Every. Single. Time.

Checking the signature of Mull installed from the DivestOS repo shows “unknown” everywhere. Just to double check, I’ve installed Mulch from the DivestOS repo too, it’s signature reads “unknown” everywhere too. Same problem on two devices (Android 10 and 14), same problem with any F-droid client, or Droid-ify.

What am I doing wrong? Why can’t I update Mull from the DivestOS? What’s wrong with the signatures? Why do they read “unknown”? Why does the signature (supposedly) change with every release (I haven’t checked/compared the keys)?

Mull is in the main F-Droid repo too, but the last version 125.3.0 is older than a month now, that’s a serious security risk for a browser! Why isn’t Mull updated frequently to be up to speed with security updates in the main F-Droid repo? There’s no issue with the signature there as it reads “F-Droid” as expected and updates work, if and when they’re finally available.

Please advise, any help is much appreciated.
Best regards

It sounds like you are trying to update one version with the other. Try installing the one from the divestOS repo (make this the preferred repo in f-droid) and then try updating only from this repo. This should work well.

  • Mull is my project and I help maintain Fennec F-Droid.
  • Mull from and have incompatible signatures.
  • Mull from is updated quickly because it doesn’t have the same merge/compile delays of
  • I directly submit fdroiddata merge requests for updates of Mull & Fennec F-Droid the same day as I push to
  • Mull and Fennec F-Droid are currently having compilation issues on the compile server.
  • Update history for various Firefox forks is tracked here:
  • Please use the official F-Droid client, other clients do not have full/proper mirror support, delta index update support, or full localization support.
  • You need to mark the repo as the preferred source for Mull.
  • You don’t encounter this issue with Mulch because Mulch isn’t in repo.
  • The “unknown” value you’re mentioning is likely the certificate signing info of the apks, this was bad jarsigner keystore generation defaults I used back in 2015 and changing the signing key would force all users to wipe their app data/re-install.

Another mull user here, thanks for a great browser. Can you please check my query here, the issue seems to be with TC I think due to shelter even multiple reinstallations didn’t help but is there anything that would help mull work like before with TC?

Fennec user here: is there a way to update it? The 126 cycle I was willing to wait but we’re on 127 now and it’s not optimal.

relan likely has fixed it, waiting on the next cycle

Ok then. :+1:

Good morning.
First of all, @SkewedZeppelin thank you very much for your project, work and efforts.
I was discovered by a mate of my campus of Mull about a year and a half ago, I was using Fennec F-Droid before.
I’m mostly really happy with it, but since the last version (125.3.0), it crashes every single time I want to launch it.
I started to get more concerned after having to install Brave to be able to browse the Web on my smartphone and seeing that Firefox 126 was released a while ago and Mull isn’t updating on F-Droid still.
Is there any reason for this?
Thank you very much in advance.
Bests :grin:.

Fennec 127.0.0 build succeeded (, will be available soon.


Thank you those for answering on the topic.

I know that the different repos aren’t compatible with each other due to the signatures, I don’t use auto update and update the apps of each repo one by one manually. No clue why it didn’t work as expected, and as I had the problem more than once, I was asking for an advice.

So, once again, uninstalled Mull, installed the latest 126 from the divest repo, then updated to latest (127), and it worked. Fingers crossed for the next upcoming update… :wink:

You may mark the actual repo as old/legacy/deprecated and create a new one with a proper signing, for new users, or those willing to switch…

See post 3 by SkewedZeppelin… Compilation issues on the F Droid repo. Switch to DivestOS repo to get the latest version immediately on release.

1 Like

Yeah, I read it too, but, issues stopping 126 for the whole lifecycle and not even being able 127?
I don’t see how to use that repo, where to get the APK, I mean, not the source code.
Seems a bit strange to me, if you ask me.
Thank you for your answer mate :slight_smile:.
Bests :grinning:.

Links and video tutorial: Our Apps - DivestOS Mobile