How to enable Repos

I’ve tried installing additional repositories from several different places, in particular, Bromite
from and input the fingerprint. When I try and access the
Repo I get the following message: This repository has not been used yet. You need to
enable it to view the apps it provides.

I went to the Repository screen and toggled the button to “enable.” I keep receiving the message that it needs to be enabled. I toggled it back and forth a few times. When I
disable the switch I get the message: Repository Disabled: You will need to reenable the
repository to use the apps.

Please let me know what I’m doing wrong or what I failed to do. Thanks :roll_eyes:

First of all, welcome to FDroid @huntclan (David). Hope you stay here longer and enjoy the cult of open source life.
Now to answer your question, this is not an issue. That toggle button only give a popup to make you aware that you have turned the repo off. If you turn the toggle on, it will not give any message as it is anyways turned on. So, when your toggle is on, the repo will work. You just need to refresh the repo list by force pulling down on any of the FDroid tabs. It will refresh and show you the repo. For additional repositories use the following link and repositories mentioned there.

Known Repos

1 Like

If you toggle on then off too fast before it gets a chance to check for index update it will go out of sync (the toggle setting and the actual status)

Remove it, add it, wait for index update…

The repository status was “unverified” when I added it manually,
but when I added it via the QR Code it added correctely. I’m not
sure if there was a typo in the FingerPrint, although I cut-n-pasted it,
but adding it using QR Code Sanner resolved my issue.

Thank you for your help.


Or I could have read the instructions on adding repos
on the website you linked to.

I apologize for any inconvenience I’ve caused.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.