Google-gate: Create a Merge Request without logging into Gitlab

Does anyone know how long Gitlab has been using ReCAPTCHA for website login? I don’t remember ever needing to use it to login.

Is there a way to make a Merge Request in Gitlab without passing through a Google-gate (ie. through a terminal window)?

I got this terminal message on git pushing to origin:

To create a merge request for ignoreMoreAutoGeneratedFiles, visit:

If you go to the bottom of the merge request page in gitlab there’s a link called “email a new merge request to this project.” That should work, but of course requires you to be signed in once to view the magic email address to send to.

If you don’t want to do that please open a support request with gitlab here that there recaptcha checker is getting annoying.

For your convenience, we have enabled Service Desk support for this issue tracker. You can create a new issue by sending an email to the following address:

  • incoming+gitlab-com/support-forum { at }

Hi Bubu,

After sending an email to that address, I immediately received an email with the subject [REJECTED]<subject_written>. The body of the email said something like, we couldn’t work out what you were saying try logging in and creating a ticket.

Regardless, I was able to login at the time (4 days ago) but not able to login all day today.

Four days ago I was also able to use my access token to use the API but mysteriously that ability has been removed also. I now constantly get a {“message”:“401 Unauthorized”}. I’m going to keep trying but I’m really struggling to see the point of using Gitlab, if they have become so dependent on Goo.

Tonight I tried replying to the [REJECTED] email from gitlab. To my surprise I received a bounce-back email from “Mail Delivery Subsystem” <>.

** Address not found **

Your message wasn't delivered to (this was not the email that I actually sent to) because the address couldn't be found, or is unable to receive mail.

Learn more here:

The response was:
The email account that you tried to reach does not exist. Please try double-checking the recipient's email address for typos or unnecessary spaces. Learn more at

So Gitlab not only require it’s user to pass through a Googate, but the email system at Gitlab is run by Goo. Ugh. Not very encouraging. This combined with their attempt at injecting “analytics” last year… ugh.

EDIT: I have a system that will keep trying to use the API, until it works.

EDIT: @hans @hotlittlewhitedog This is the branch I’m trying to create a MR for

The problems experienced by me, being the API lock-out (and the Googate incumberance) have been added to a topic on the Gitlab forums.

Here’s hoping the API problem especially is rectified asap.

As an aside is there any real reason to use Goo’s ReCAPTCHA when there are open-source alternatives? I thought Gitlab prided themselves on being open-source but then they put in ReCAPTCHA, haha.

Another merge requests,@hans (but the API will not let me do them):

Speedy Localhost Development (and possibly testing) Repo:

The testing repo has 31 apps (more than 30 triggers the pagination). This merge request would span two repos…

  • fdroid-website: the content of the ‘testing-repo’ and the _config.yml switch.
  • jekyll-fdroid: the enabling of ‘testing-repo’.

Please tell me if you have any comments and concerns.

The fast testing mode is a good idea, the tricky part will be getting it integrated so that it doesn’t make the existing build methods harder to maintain. They are already very complicated. I think for now, the best bet is for you to maintain it in a branch, then rebase it as you want to test things.

If you want to avoid Google tracking, why not use Tor Browser? You can click through the captcha using Tor Browser usually. You already have a account.

I tried to make it as easy to read, but can be made easier. I did have a comments above a couple other lines of code. Maybe some whitespace too? I’m happy to leave it till later as I’m probably the only person who really needs it right now. :slight_smile:

I’m avoiding logging in completely by trying to get the API working as it was. The following doesn’t work:

curl --socks5-hostname localhost:9050 --request POST --header "PRIVATE-TOKEN: <MY_PRIVATE_TOKEN>" \
> --form "id=13996952" \
> --form "source_branch=fastLocalhostTesting-pairWithJekyllFDroidChanges" \
> --form "target_branch=master" \
> --form "title=Speedy localhost development  (accompanies 'jekyll-fdroid' repo branch)" \
> --form "description=Please see the commit message. NOTE: Merge Request submitted over API so it may take time for me to receive comments over email. Maybe find me (as webDev) at the [f-droid forums](" \
> --form "target_project_id=2151437" \

And yes, it doesn’t work when not going over port 9050 also :wink:

With, you have to log in to use the API. They don’t allow any access without the token, generated from a valid user ID. GitHub allows very limited use of the API without a token/login.

Since ~29 Aug, 2019, fdroid-client cannot be mirrored anymore to another Gitlab fdroidclient - 13:CreateRepositoryFromURL: clone cmd wait: exit status 128. Please try again.
Any idea ?

It could be so many things, but mirroring a git repo doesn’t use any special access, it uses the regular git protocol like doing git clone --mirror on your machine. Seems most likely an issue with that other gitlab istances

I tried today to re-init mirror from beginning, via a browser, on my Giltab account and after 5mns it returns the error fdroidclient - 13:CreateRepositoryFromURL: clone cmd wait: exit status 128. Please try again.

On my previous fdroid-client mirror, since 29Aug 2019 it fails with email notification : unable to access requested URL returned error : 301

All my others Gitlab mirrors work fine. (Also I don’t use any SSH key.)

Thanks for the heads up. Its counter-intuitive, given that git operations can be done without logging-in. Also they don’t seem to mention the need to be logged-in in any documentation that I came across. :frowning:

If I continue to have trouble, may I use this topic to suggest a merge with a particular branch?

Its easiest for everyone to track discussions about merge requests in
issues and merge requests on The issues are a good place to
discuss the problem you want to work on, ways to implement it, whether
it would be acceptible to the other contributors, etc. And merge
requests are the best place to discuss the code, once its working.

Ok, fingers crossed the login and API are not troublesome.

Last week I was able to login once but still could not use the API.

The actual website doesn’t load merge request info. On individual merge request pages I’m not shown any Commits or Comments. They simply don’t load. I get spinning circles and that’s it. That’s with all javascript enabled. I’ll look into it in more detail if I have any further trouble.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.