F-droid updating repos error

Last couple of days I’m getting this error when trying to update. I’m on Oneplus 7T with latest OOS and Magisk.

Anybody knows what might be the problem?!

Screenshot_20210124-183115|225x500

2 Likes

Same problem. “Could not sync F-Droid Archive. Could no parse the index file.”

2 Likes

and @avalx
Haven’t encountered this so I turned on F-Droid Archive and it gave the same error:

I think it should be something to do with the archive repo, not your problem. Try switching off syncing the “F-Droid Archive” repository it should help. In settings press repositories>switch off F-droid Archive

Btw I don’t think you need the archive anyway, the apps in the default one is the most updated and well designed.

1 Like

Yes, I found out that too. Perhaps somebody could check the archive repo anyway.

1 Like

Good afternoon:

I also have the same error: https://ibb.co/zxvDQTy I already deleted cahe, remove sources, put sources but nothing.

There is no way. I’m in the latest version of fdroid app

A hug

Please disable the Archive repo. It has a lot of issues on interacting with the main one.

Why would you need that repo exactly?

1 Like

Not needed, you won’t need the archive anyway. To be exact, apps you are using and downloading from the F-Droid app and from the website are from the main F-Driod Repo, so the archive is uesless at some point.

@gallegonovato @avalx This will help you out with the error message, you don’t need that archive repo.

1 Like

I don’t know, it was enabled in my config as long as I remember and I thought it’s needed somehow. I disabled it and it’s OK now.

IMHO, if it’s of no use maybe it should be removed from default F-droid installation.

2 Likes

It is of use, for experts that need something special but they can also handle any issues.

We don’t have a warning in place, true.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.