F-Droid App Doesn't Load Images

When I open up F-Droid it dosen’t show any of the images even though im on wifi with a fast connection. Anyone know how to fix this

try the latest version, v1.2

I’m on 1.2 (tested the latest 1.2.1 aswell) and have the same problem. The thumbnails will show on first launch (also if I clear the app data/cache), but on subsequent launches almost all app images is missing.

This has been the case for me for atleast 1-4 months (dont have any versions to refer to here, unfortunately).

I can’t reproduce this. If you can, please file an issue and give the steps needed to make it happen. Most of the time, that’s 90% of the work needed to fix a bug.

Try deactivating the F-Droid Archive Repo. For me that’s the only way to have F-Droid load the pictures and icons for the apps in the Standard Repo.

1 Like

I can confirm, this also solves it for me.

Hm, cannot confirm this working for me. I have the same problem and I am not able to fix it.

Had several activated repos (F-Droid Archive, Izzy etc.) deactivated them all, cleared the F-Droid cache, activated only the official F-Droid repo again - still no icons or screenshots for about 90% of all listed apps. For example when I look at the list of recently added/updated apps right now all apps between c-beam and Nextcloud Talk don’t load any icons or screenshots - but Nextcloud Talk (has icon/screenshots/header) and c-beam (has icon) work just fine.

I’m using F-Droid version 1.2.2 on a Moto G4 (athene) with the latest official build of LineageOS.

Where did you get the latest F-DROID app version? I downloaded the app again today from their website, but it’s showing version 1.0.2? @hans @CryptGoat

@Phillyslickster It’s the latest stable version available in the official repo: https://f-droid.org/packages/org.fdroid.fdroid/
You should get an update notification in F-Droid itself too.

Thanks for your response.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.