F-droid app broke itself

Hello

I have a new phone. I downloaded the fdroid apk yesterday and installed it. The client app worked fine initially, it updated repository and I installed two apps. I got a notification that there is an update for fdroid client and I installed the update.

At some point, I am not sure exactly where, the fdroid client app crashed. I think it was in connection to the client update.

Result: In the client app I see nothing. The “start page” is completely blank, “Manage installed apps” thinks I have no apps installed, but that is incorrect since I installed two apps and they work fine in themselves.

How do I fix this? “Clear cache” for the client app? Reinstall the client app? Something else?
Will it loose track of the two apps I installed before the crash?

Thank you for your help

No. You can try reinstalling it or clearing the cache until it works.

What is the recommended method of reinstalling the fdroid client app? Should I uninstall and then install the apk again?

Ok, I solved it. What I did:

  • Clear cache, did not help.
  • Uninstall & install again, after that it started working. I also had to do a “Delete app data” after the reinstallation.
1 Like