F-Droid 1.9 fails to install applications

Hello everyone,

I have F-Droid 1.9 installed on Android 9. Every time I command it to install a new application it displays an error message like:

The requested file was not found. https://f-droid.org/com.beemdevelopment.aegis_25.apk

By now I tried dozens of different applications and it always fails with this kind of message. Can anything be done about it?

Thank you.

Did you enable autosync/downloads/updates in F-Droid Settings?

You can verify by looking at Settings-Repo-F-Droid…I guess you’ll see the last update date as really old.

Setup auto stuff, then go to Latest tab and pull down to force an index refresh…then retry to install.

FYI F-Droid keeps only the last 3 releases in the main repo.

Thank you for the reply.

I installed F-Droid today on this system. I do not have a Repo section in the Settings menu, rather one called Local Repo that contains no update options. In the Updates section the Automatically fetch updates option is switched on, was like that by default.

Any other ideas welcome.

Under Manage installed apps? Above Wi-Fi there’s nothing?

Alright. That menu is called Repositories in my case. But I am yet to figure what “Setup auto stuff” actually means. In that menu all the repositories are switched on.

Repos…right…so F-Droid…last update?

Got around to pull to refresh in the Latest tab yet?

Don’t enable the Archive repos

Slide Wi-Fi & mobile all the way to the right

Toggle auto install ON, put interval to 4h

Please take a look at the image attached. There is no Auto install option, only Automatically fetch updates. The latter was on by default.

Right, sorry translation blunder.

Got around to pull to refresh in the Latest tab yet? Then retry…

1 Like

Still getting the same error reported in the first message. The Updates tab remains empty.

You have phone Do Not Disturb mode on? Maybe that prevents F-Droid functioning properly. I would turn off do not disturb and try again.

You could try:

Settings, Apps, F-Droid, Force Stop; Storage, Clear Cache. Start F-Droid, swipe down for refresh. Install app.

If that doesn’t work, repeat above, plus
2nd time also Clear Data. Start F-Droid, choose repos, swipe down for refresh. Install app.

If that doesn’t work, repeat above, except restart phone before starting F-Droid.

There is F-Droid Version 1.10-alpha0 you could try. But sounds like you would have to download the APK from this page:




but this method is not standard.

Edit: I’m ASSuming in aegis_25.apk the 25 is a typo because 35, 36 and 39 are available now.

1 Like

Picture of the repo F-Droid page pls

I managed to get the Updates tab working following the hints from @justsomeguy. First going to the individual app storage menu: Settings > Apps > F-Droid > Storage. There I used both the Clear Cache and Clear Data buttons. After this it became possible to install programmes from F-Droid.

Thank you all for the replies.

That just forces an index download… .just like I’ve asked you to do above “pull-to-refresh in Latest view”

Almost the same. Except the minor user experience difference: Sometimes one works when the other doesn’t. Almost like there’s a stuck “too many refreshes flag” bug.

The result of a pull-to-refresh might have been useful to know if it fixes it, if an old index was indeed the issue

Swiping down the Latest tab does not show any updates. Not now nor before emptying the cache and data.


That not what it’s supposed to do…it just downloads the index…

I Keep asking for: Repos... F-Droid…last update date can you actually tell or put a picture?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.