No updates unless I disable Archive repo

It seems sometimes since last year the F-Droid client stopped auto updating and it took a while for me to realize. Prior to then I got notifications when apps where updated. Now I’ll only get prompted to install new apps when I manually disable then enable repositories in the client. How can I get back to the old behavior?

I used to recommend trying a force stop, clear,… start again routine. Now I recommend switching to F-Droid Classic.

Device? Android version?

I’ve seen this once before a few months back, only the archive repo versions were suggested.

Was Archive on top of the repo list order?

Was on bottom top

List order doesn’t appear to be respected for a few versions now.

I’ll try to repro again

I’ve toggled it a few times and tried with archive version, suggested version, and not installed and cannot reproduce on 1.15.2.

Moto X Pure Edition, Android 7, FD 1.14

Thanks I’ll look into classic as an option.

My order from top to bottom:

  • F-Droid Archive (disabled)

  • F-Droid (enabled)

  • Guardian Project Archive (disabled)

  • Guardian Project (enabled)

Reordering doesn’t seem to be possible by drag and drop?