Error getting F Droid index file

Bonjour,
Après l’installation de F Droid, le message " error getting F Droid index file " s’affiche. Aucune application n’apparaît dans le dossier “paramètres/applications installeés” alors aue j’ai téléchargé et installé Telegram (directement sur le site).
Dans les onglets “nouveautés” et “catégories”, toute recherche mène systématiquement à la réponse “aucune application de ce nom disponible” (en recherchant à nouveau Telegam par exemple).
Faut-il configurer F Droid pour pouvoir télécharger des applications ?
D’avance merci pour votre aide.

1 Like

Network issues? Wi-Fi or mobile data?

I have the same exact problem. In fact I’ve had this problem for a while and thought it would be resolved somehow. But I’m able to repeat it reliably as follows:

  • Installed f-droid 1.6 from https://f-droid.org/FDroid.apk on lineageos 16.0-2020-0124
  • Mobile connected via wifi
  • The list of new applications shows applications
  • Reboot
  • Open f-droid
  • The list of new applications shows nothing
  • Searching for VLC (or anything else) shows nothing

Swiping the screen down shows a bar “updating repository” and (after a minute or two) the list of new application shows content again.

I discovered this “swipe down” feature by accident and tried every possible menu looking for a way to update the repositories or otherwise figure why nothing was shown.

I’m not sure what I’m doing wrong and why I’m always ending up in a state where f-droid shows nothing. See also a similar issue on gitlab.com.

That’s a hallmark of mobile UX interaction (to “update app content”) since 2007… welcome to the future.

What device? What F-Droid version?

Samsung S4 lineageos 16.0-2020-0124

1.6 which is the version available from https://f-droid.org/FDroid.apk as of today

Your remark ridicules my ignorance and hurts my feelings.

After upgrading to 1.7.1 and rebooting again, the list of categories is populated instead of being empty. Which begs the questions: why is 1.7.1 it not the default on fdroid.org ?

It’s complicated: Why does the F-Droid website nearly always host an outdated F-Droid apk?

Oh, c’mon…

There were some reported bugs regarding this, maybe fixed in the latest versions (stable or alpha)

And this is dismissing my feelings, which makes me feel even worse. Is there no code of conduct on this forum?

Bonjour, j’ai exactement le même soucis, mais je ne comprend pas grand chose aux réponses, malheureusement ici ou ailleurs, je ne trouve que des réponse en ANGLAIS, déjà, que je ne suis pas excessivement bon en informatique, en anglais non plus, alors en anglais technique informatique, je vous laisse deviner…
As-tu trouvé une solution ? ou es-ce que quelqu’un a une solution ?

Bref j’essaye de me de-googlisé, mais là, je bloque complet…
Merci de votre retour.

La solution est de faire glisser son doigt de haut en bas pour déclencher une mise a jour des dépôts.

Fait, fait et re fait… dsl j’ai également désinstaller plusieurs fois, réinstaller… j’ai même réinitialiser le téléphone… Bref j’ai pour ma part tout tenter… .

After you slide down…does a bar appear on top saying that it updates?

Does a toast message appear in the lower middle part of the screen saying what error occured?

Just say you didn’t mean to.

Don’t take offense. He’ll help anyone but tends to be expedient about it. I’m surprised that that response almost spilled onto a second line. It must mean he wants to help more than normal. :stuck_out_tongue:

hi,

Mrs,Mr,

I read all post . I would throw the post because I have the same issues and i need a help please.
So in order to explain my fdroid and my repo works all good since mid March.
Next impossible to find my apk in my repo the message I can see when update ( slide top and down ) I have this message “error getting F droid index file” .
I try yours advice like dachary but not works.
I create a other repo with the documentation " Setup an F-Droid App Repo" but not works.
I change my version of fdroid (1.7.1. and 1.8 ) but not works.
So someone can help me please ?

PS : this is my config I use fdroid 1.6, Server Debian 9 , 30 GB
I am French I hope which you understand my message and I am sorry in order to my fault spelling.

What device? did you read Error message while updating the fdroid repository yet?

hi,

Licaon_Kter thanks to reply me I’m not read.
When you deal of device it’s my cell phone ?
I use a crosscwall and my version android is 7.1.2.
I try the post " Error message while updating the fdroid repository".
when I install v.1.8 I have this message “Error getting F Droid index file => no mirror available”

Both mobile and Wi-Fi sliders are all the way to the right in F-Droid Settings?

My device is a crosscall model action X3.
Version Hardware : V1.00
Version of software : L1047.6.06.02.FR01
And the wifi silders and data mobile is all way right in fdroid settings.

Hello,
I have a slightly different issue, that you can see here Error message while updating the fdroid repository. This happens with these following settings :

But when I change the index format, and I uncheck “Force old index format” this happens:

So i get the same error message “Error getting F Droid index file => no mirror available” then @monkeydjohn

(Pour ceux qui ne comprennent pas très bien l’anglais, je suis français, donc je peux toujours répondre en français…sinon il y a toujours des traducteurs en ligne)