Cgeo: updates only available if I deactivate and reactivate the package repository

#1

I’m using the c:geo repository (https://fdroid.cgeo.org) with Fdroid 1.6-alpha2 on LineageOS 16.
If a new app update for c:geo is available (shown in c:geo), the FDroid-App doesn’t show that update in the list of versions in the c:geo page inside the app and doesn’t show the update in the update tab.
I have to deactivate the package source and reactivate it; than, the update is shown and I can update c:geo.
It is the second time I have these issue, the first time with an older version of the FDroid client app (around 23 February 2019).

Current version of c:geo: 2019.04.04
Old version of c:geo: 2019.02.23
FDroid version: 1.6-alpha2
Android Version: 9 (LineageOS 16)

c:geo is a geocaching app for Android.

I think it is a problem with the FDroid client app so I post it in this forum.

0 Likes

#2

Some logs would be nice, grep for that package name I guess.

0 Likes

#3

The problem is that I can’t reproduce that issue until the c:geo team publishes the next release.
Do you mean logcat logs and fdroid as package name?
I record a logcat file while

  • refreshing the repos
  • enable c:geo repo
  • refreshing the repos
  • disable c:geo repo
  • refreshing the repos

although this does not reproduce the issue and may not help because of that.

How can I publish that log in this forum? If I use the </>-Button to create text, in the preview it doesn’t differ to other text at all.

0 Likes

#4

If you didn’t reboot in the mean time maybe the log still has some past info.

0 Likes

#5

The problem is that I reboot the smartphone periodically so I don’t have that logs.
I have a old backup from FDroid with an outdated update from c:geo-Repository what I tried to use to reproduce the issue but oandbackup failed to install that backup and broke my FDroid installation so I had to repair that first. The problem was that I can’t open FDroid and can’t remove it.
After an reboot FDroid doesn’t show up in any app list, but if I can’t reinstall it with an apk from the FDroid website. The apk installer only say that “FDroid is not installed”. I checked the logcats and the error was that there are parts of the FDroid installation remaining that cause Android only accept the current 1.6-alpha-2-Version of FDroid or newer versions.
The FDroid Website didn’t offer a link to 1.6-alpha-2 but only to 1.6-alpha-1 so I had to guess that link.
Now I installed FDroid again and it seems to work.
Sadly I had a lot of trouble and don’t get anything closer to the c:geo-repo-update-problem :frowning:

Edit: the problem with oandbackup occurs because FDroid had updated it to an x86-64 version although I have an arm device. I fixed the error while installing a newer, universal version. (I had to remove oandbackup first because FDroid saw the upgrade as a downgrade and blocked it)

0 Likes

#6

Ok, now I installed the correct version of oandbackup, but the restoring of the backup still fail.
I will wait until c:geo makes the next update and record the logs.
By the way: Are there more detailed logs than the logcat-logs for F-Droid?

0 Likes

Mastodon