Can't uninstall apps (package installer stopped working)

I’m having problem uninstalling 2 apps that installed from F-Droid, on my Galaxy A52 running on Android 13. I have checked previous topic but I mostly didn’t understand the language cause I’m not a developer and their systems are rooted and I don’t want to root my device. I cleared caches and datas of the apps and it didn’t work, installed the newest version of package installer from apkmiror, updated F-Droid but it didn’t help either. Anyone has any advice?

If you are able to install, that means package installer IS working. Try force stopping the package installer from all apps section (remember to have system apps visible as well).
After force stopping, reboot the phone once and see if uninstallation works.

Thanks for your time Harry, just tried it now but still can’t uninstall… Than cleared cache and deleted data and force stopped and rebooted, still won’t uninstall…

Can you share what apps are those once? Also share snaps of the F-Droid for those 2 apps pls.
Those maybe some system app, but may reflect under FD as well. Like playservices, gms etc.

They are 2 simple games named Pocketbrooball and Ricochlime. I even updated brmball just in case but still got the same response. Also nothing happens when I try to uninstall them thru F-Droid…

Did you try to “degoogle” and remove or disable any packages, perhaps via adb?

@SkewedZeppelin Even though I disabled most Google apps on my phone I’m still using some features of it, so I can’t completely degoogle, if that’s what u’re asking… I don’t know anything about adb, but if that’s the only solution I guess I’ll have to find a PC first :confused:

Do you have an SD card? If you do can you remove it and then try to uninstall?

ADB should allow you to uninstall it eventually: App refuses to uninstall (package installer stopped working)

you probably disabled an app you shouldn’t of.

on stock Android devices there is a Google specific package installer which also handles uninstalls

1 Like

@Licaon_Kter this is a double-sim phone and i use both slots, but stupid as it is i had to sacrifice memory card slot to be able to do that. So I don’t have an SD card…

@SkewedZeppelin I have just uninstalled F-Droid app and a couple of apps I installed from PlayStore and had no problems with them…

You should try disabling the apps from Settings > Apps, then uninstall. If that fails, restart in safe mode and attempt uninstallation. If still unsuccessful, contact F-Droid support for guidance.

Actually it is not related to F-Droid. There seems to be some issue with the PI itself. MIUI forum is the best way out.

Problem solved! I always install all system updates, so didn’t thinks it could be related to that, but after updating the UI I was able to uninstall both of them.
Thanks everybody for your time :saluting_face: