App refuses to uninstall (package installer stopped working)

what options are there when uninstalling an app doesnt work with the builtin package manager?
it keeps crashing with error stoped working.
from fdroid i installed a game, idTech4A++ | F-Droid - Free and Open Source Android App Repository
i think this should be the package name? com.karin.idTech4Amm_11035.apk
so got the adb platform tools on the pc and ran uninstall -k com.karin.idTech4Amm_11035.apk
but that did nothing. now when i enter adb devices it cannot even start the daemon which worked before… usb debug is on with filetransfer
phone is rooted
tried the bloatware uninstaller app with su permissions but the game isnt listed there, how can i remove it?

system is a clean install of latest lineageos

make sure to run adb kill-server several times, or maybe sudo adb kill-server just in case, then retry.

Why did you run uninstall with -k ?

If you run adb pm list -e can you see the app in the list?

Do you see your app in your launcher? in Android - Settings - Apps? In F-Droid - Settings - Manage apps?

i ran it with -k because the website i was looking at said this was the right way.
i dont know what the parameter actually does.

yes i can see the the app in the appsmenu and in the froidmenu.
when i press uninstall i get “package installer keeps stopping”
“app info / close app” are the only options, and info only open the package installer app permissions, doesnt give info about the crash.

adb shell pm list packages
so it is there.

  • daemon started successfully *
    lineage_gsi_arm64:/ $ pm uninstall com.karin.idTech4Amm_11035
    pm uninstall com.karin.idTech4Amm_11035
    1|lineage_gsi_arm64:/ $
    C:\Program Files (x86)\ClockworkMod\Universal Adb Driver>

tried deleting the app with rooted termux, returns: Failure [DELETE_FAILED_INTERNAL_ERROR]

should be pm uninstall com.karin.idTech4Amm

pm uninstall --user 0 <package_name>

pm uninstall com.karin.idTech4Amm
pm uninstall --user 0 com.karin.idTech4Amm

both return
DNS server not authoritative for zone.

On Windows: so you start adb shell and IN THAT SHELL you run pm ... and the error is about DNS?

What if you run normally adb uninstall com.karin.idTech4Amm ?

Can you get older platform-tools r33 for Windows instead? and use adb from this one?

1 Like

@Jaegerschutze Run this command in Termux or any Other terminal emulator.

Make sure to run this command as root user

1 Like

Thank’s for helping, appreciate it!

adb shell
pm uninstall com.karin.idTech4Amm

That worked. I forgot to add adb shell first… and no idea where i get the _11035 from.

What was the cause for this problem i wonder? Why did the packagemanaer crash when trying to uninstall this app?
Could my lineageOS GSI be the cause or the app creator?
I didn’t have this issue with any other from the f-droid store so far.

11035 is the F-Droid app build id. If you see it on the application download page, it is written there.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.