Beware for the FINDMYDEVICE app -- cann't uninstall

Downloaded through f-droid app, cannot uninstall through it. Phone system setting uninstall tag dimmed too. — No way to uninstall.
Click the “share” link on findmydevice app through f-droid will show link “connect and trade apps with people near you”. No such quotations for other apps when click “share” through the f-droid app for other downloaded apps.

When check for malware with Hypatia. Hypatia “isn’t responding” . Never happen before findmydevice was installed.

Disable it from device administrators first…

3 Likes

safe mode, cannot uncheck deactivate device adaministrator.
using marshmallow.

Boot in normal mode then. You cannot uninstall an application that has the device admin privilege.
I wonder why you are in safe mode anyways.

first I tried to deactivate through normal boot but cann’t uncheck and “Unfortunately settings has stopped”, that’s why i use saafe mode : same result as above quote.

Now at your request i tried normal mode again but reult same quote. (all time able to uncheck other app device admin) using steps as above.

Now what do i do?

So Settings crashes when you try? Android bug then…

Try to report to the app dev too, and maybe there’s some ADB magic that can unregister it

i wouldn’t say that is android bug, as i was able to deactivate other app adminstrator through the mentioned steps (see last message)
this FINDMYDEVICE app changed system setting. He is the satan.
He is the owner of my handset now. haven’t tried ADB yet. i am not sure if i am proficient in using command line program.

Looking at https://gitlab.com/Nulide/findmydevice/-/issues, it doesn’t seem anyone ever told the developer this is happening.

You really should first tell the developer you are having issues uninstalling it so they can try to help before you call them evil.

How is the developer supposed to know something is wrong if nobody told them?

1 Like

Edited: Whoops, sorry. I mixed things with "Vigilante" app by "FunkyMuse" not removable, creator says it is fault of F-Droid - #6 by pazos

I’ve said it here somewhere before.
It is very possible for the Android package database to end up in weird states, especially on older versions like 5.x as you mention.

You can either attempt to root your device or factory reset it.

It does appear the MDM capability can let it drop itself without going through Settings.
So maybe kindly ask the developer to add that as an option before you call malice.

The description clearly mentions Satan too though

/jk

Had you read this developer app description by himself?
I had no trust or faith in him. Don’t want to be trapped further to my location, personal i.d. phtotos, contacts, etc — personal data. 100% sure he knows what he is doing.

He stated blame the satan. What is weired as i stated in the first message, when you click the share link this statement popped up “connect and trade apps with people near you”. I do not want more people suffer. Period.
Most likely he was able to change system setting through the APK (for older Android version?) without my rooting.
Trade? What does that mean, ---- sounds like a ransome ware to me.

is MDM mobile device management? I am naive with that.
Think i will have no choice but to factory reset it if no other solutions exists.

But the thing is how come other apps (like Nova Launcher, Key Mapper, T-UI) i was able to deactivate even in normal mode through the setting? , and his app caused popup window “Unfortunately, Settings has stopped” and the device falls back with his app still checked.

Yes, nothing is safe, even FOSS could have satan.
Wish you guys luck.

Honestly, if anything here is evil it is the company that made your phone who didn’t care to give you an update with the bugfix @pazos mentioned. Unless your phone is really really old, like, 10 years or more, it is plain evil to sell such an outdated Android version without offering any updates.

A factory reset is probably easiest, although reading the bug report @pazos linked it seems that temporarily removing your SD card might also help to make the Android installer not crash.

5 Likes

I think @pazos stated the nonremovable app is not this findmydevice.
2ndly, i suppose all manufacturer will stop update the osr 3 or 4 years after market.(but Google stuff will to its advantage for tracking end user).
My os is Marshmallow and has no slot for expanding memory.
Can you explain how come i can deactivate through seting other apps admin and not this one as i stated in the last message?
I do believe factory reset will do the job anyway.