Workaround for installing GmsCore ( directly alerts 'not installed' )

Hi guys, I’ll keep it short but here’s a problem I’m trying to solve for about two weeks.

I’m on a shiftphone with android 8.1. With ShiftOs-L (google free) Installed are F-droid and Privileged Extention by default. I’m trying to get Micro-G to work.

What I’ve tried:

  • Installing GmsCore (from their repo in fdroid) gives an error ‘not installed’ directly before doing anything. (more on that here but way too technical for me) Update: todays repo update (21 oktober 22) gives the same error.

  • Installing previous MicroG from their Archive repo (in fdroid). Instals, works, but in the selftest it says something like ‘UnifiedNlp (1) is not compatible with your system, please install another version or Xposed component’

  • Installing GmsCore from their website by downloading and double clicking. But then it’s installed by the app manager and not Privileged Extention, so it’s not in the system/priv-app. Also, it seems to have ‘UnifiedNlp 2 Alpha’.

Little note: I really really can not understand this root/flash/bind/adb etc. (I’ve tried!)

The question: Can anybody give some help on either:

How to install the latest GmsCore through F-droid

OR

How to install the downloaded latest app somehow through the installed f-droid app on my phone?
(so it will use Priv Ext app which installs it in system/priv-app) (maybe by creating a local repo with the downloaded app on my SD card and then let Fdroid scan for repos on SD card?)

OR

How to install UnifiedNlp 2 Alpha
(or other package that gets this thing to work)

Thanks a bunch in advance!

If you’ve gone two weeks without microG, extend the time. If GPS works, you don’t really need unifiedNLP. Welcome to android (almost) without google apps!

System App Mover
I guess.

IDK your setup seems so messed up for me… magisk, exposed? android 8?, bootloader unlocked?
If your phone is axolotl (SHIFT SHIFT6mq) and has the bootloader unlocked(and can’t lock without brick?) i’d just install LineageOS4MicroG if i want microG, and don’t root(magisk) it.

@anon46495926 thanks but gps isn’t working (and MicroG doesn’t need it) so I need a workaround for MicroG to function.

Thanks @Morgoth , but System App Remover needs root, and I have no knowledge on how to do that. (that’s why I would like to use privileged Extention since that can handle the system/priv-app directory) So also Magisk, Exposed, unlocked bootloader, adb, flash etc are out of my league. (I’Ve read a lot about it by now but just can’t understand it and I don’t want to mess up my new phone by ‘trying something’.

My phone is working perfect and I’m happy with it, except for ‘location’, and I think you need MicroG for that. Most people have it running fine, and I just can’t figure out what the problem is here on my device, that’s why asking for the work-around.

@timmo
UnifiedNlp has absolutely zero impact on GPS lock speed or functionality.

Yes sorry for not being clear but I ment to say it’s not gps that’s the problem since MicroG works with wi-fi and cell towers. They advice in the manual advises to set location on ‘anything but gps’.

Who? Why? What benefit?

Probably because the gps setting is only gps, and wifi and cell towers are needed to. Maybe also because gps can only be done through google servers. Not sure. Do you mean there is a way to use gps without google services?

@timmo

GPS doesn’t use Google services or servers.

Wi-Fi and cell towers are not required, they are merely a nice to have for quickly determining location when indoors.

I also don’t understand why you’re running outdated, unsupported, and extremely insecure Android 8. You can be on Android 12.1 or 13 on the shift6mq.

Thanks for the feedback @SkewedZeppelin

I’m on shift5me, android 8.1 with latest security updates from last year. Shift mentioned they are working on 12 for this model, so that might come up later. I just really like this phone.

So if gps isn’T a gogle thing, how would you implement location services on this 8.1 without google services?

There was a small issue with updating it on LOS for microG ROM before, but none of the aforementioned ways from that link are working now, which is caused by signatures incompability (was fixed yesterday) or just some random error that says “Not installed”, when you try to update it from repository.
Yep, you probably can update it by downloading and installing an .apk from github or microG site, but it won’t update itself in /system/priv-app folder, bringing only additional bugs.

1 Like

So it’s fixed or not?

Pics of your repo order setup?

Pics of app details in F-Droid with Versions expanded?

Seems like it does, f-droid shows it just as regular update (before that it was warning about incompatible signature for some reason), but giving error “Not installed” every your try of updating it.

Спойлер

microG repo was deleted and then added back again to avoid showing it under the name “UnifiedNlp (no GAPPS)” instead of the “microG Services Core”, so it’s placed at first (at the bottom).

Спойлер

1 Like

And App Manager confirms the same signature?

Is that what you meant?

Спойлер

But here is more detailed info about installed version and .apk from github or microG site:

Спойлер

2 Likes

Hey thanks @Danko for joining! And yes, confirmed from me too that new repo still gives the same error. BUT are we sure the problem is signature? Because here they say the problem is about redirecting. (@Licaon_Kter is actually in this subject)

Ah, and @SkewedZeppelin , not sure if you read my question, but if gps isn’t a google thing, do you have an idea of how to implement location services on this 8.1 without google services? Would be great to have this since it’s the whole point of why I’ve opend this post. (edit: i think you might be refering to apps, which do work without google, but I am referring to browser/websites using gps/location, sorry for the inconvenience)

I seem to have misunderstood your first post. Sorry.

1 Like

Today’s morning the problem was finally (I’m not sure) gone and update works — those redirection in microG repo was temporarily disabled, as main developer said.

1 Like

Works!

Big thanks @Danko and @Licaon_Kter (and all the others)

Ah, and for those testing location in a browser, duckduckgo did not work (as nicely neglected in this post) but Fennec browser did work.