Updating not working?


#1

I’ve been swiping down on the home f-droid screen (latest apps) everyday for the last two weeks but the repositories don’t sync and the same latest apps are shown.
I tried clearing the app cache but no change.
I tried downgrading to 1.3.x. No change.
I tried re-installing 1.4. No change.
I tried changing repositories in the settings and the repos do update but the same apps are shown on the latest apps screen. No change.
Any suggestions?


#2

I don’t think they’ve updated the apps since about 27th September. It might be to do with the recent upgrades they’ve been doing but hopefully they’ll update the softwares soon.


#3

Wait for the update to actually be published, as said above, there was no recent update, only the build cycle has run several times.


#4

Thank you guys. Good to know :+1:


#5

Do I understand correctly that there have been zero app updates across F-Droid in the past week and a half?

Could we add a system that tells the users if apps have been updated but F-Droid hasn’t published updates?

I know that frequently it can be a week or more before F-Droid publishes updates even after the updates have been pushed by app maintainers. I’m trying to think of some solution to this that would at least let users know if app maintainers haven’t release updates or if the build process is on hold for some reason.


#6

Conversations has been updated and built about a week ago, but did not get published yet: https://f-droid.org/wiki/page/eu.siacs.conversations


#7

Maybe this was at fault: https://gitlab.com/fdroid/fdroidserver/issues/578

Sure, look at last build date for something then look at your calendar… did more than 2 days passed? Oh well…


#8

Go to the app’s page on the F-droid website and click build metadata and you can see right away which is the latest that F-droid grabbed. Not too sure about how it’s decided when to make the updates available but as long as it’s roughly a week that’s not unreasonable IMO. If it gets sped up, great, but not a huge issue.


#9

That’s just the metadata…see the steps here (watch out for step 4!): NewPipe update request


#10

Thanks everyone. Updates came through for me yesterday so all is good. I just thought there may have been something wrong with my F-droid because I always got updates every 2-3 days before.


#11

Oh that’s good, ought to go in an FAQ somewhere lol


#12

^^ Confusing, all of the update options are available in Settings; and even IF there aren’t any updates, you should still see the connection dialog (it won’t be downloading anything) and it comes up in app notifications. Screenshot @

EDIT:

Whoa, really?! Ok, that kinda sucks!! :)) *Oic


#13

Sometimes yes, at the moment they’re kinda every 2 days.