Upcoming alpha release of F-Droid Client

At long last, the first alpha of the big overhaul of the official F-Droid client app for Android is about to be released. This round of work was focused on modernizing some of the oldest code in the client: the downloading, index parsing, and database layer. This code is now structured as standalone libraries so that other projects can benefit from this code as well. This changes a huge amount of code, and we have already confirmed it fixes many bugs and improves a wide range of functionality. There will be more on that here as it is finalized.

This also means that there will be breakage, so this alpha will probably be more unstable than previous alphas have been over the years. We always appreciate testing, feedback, issues, and crash reports. But if your F-Droid is customized in a way you would rather not reset, then you might want to sit this alpha testing round out. If you have a spare device, test device, or work with Android emulators, we also are happy to have testing on our nightly builds. Be aware: the nightly builds come from GitLab CI/CD, so not as secure a release process as the official releases. It is possible to have both official and nightly installed at the same time. The easiest way to get started with the nightly builds is to add the repo to an existing F-Droid install, then search for “Nightly”, then choose “F-Droid Debug”.


Not sure if just me, but 2 things.

  1. The nightly repo link above throws error as page not found.
  2. When adding as repo, I get could not parse error.

As expected… that’s the link to the repo for the Client not for a browser

Pics? Which Client version did you add it to?

1 Like

Ahh, gotcha.

Droidify. I removed the repo that time. But now that I readded, it syncs. Maybe I had some network issue that time,

1 Like

One thing I wonder, is if that will fix the issues/inconsistencies I noticed in the F-Droid app.
Namely that when I refresh the sources, that the exact same apps I have show as having an update, even tho they are on the latest release.

I really hope this will be fixed in this upcoming update!

@Andre601 Please let us know either way

I honestly don’t quite understand what you mean exactly (language barrier goes brrrr haha).

Do you mean let you know once the update is out or let you know now?

Either way did I reinstall fdroid and it’s not showing the same spps as “update available” (also, another app I installed now shows as installed too which wasn’t the case before).

Please let us know if the problem you saw fixed in the new version. You need to update to the alpha/nightly version to check it.

1 Like

Yeah. I honestly will wait for a more stable release. Not a fan of nightly builds for that matter and I feel like the re-install may have fixed it already. Tho I have to wait and see.

So we have our first issue to warn people about: some people are seeing that v1.16-alpha0 wipes their custom repos. Here is where we are tracking the issues:

I tried it out and it seems to be working.

I noticed it is still targeting Android 7. Is that expected to change before the stable release?

v1.16 will keep the same targetSdkVersion unless a new contributor steps up
and starts fixing the things that need to be updated in order to use a newer
targetSdkVersion. The biggest piece of that will probably be the Storage
Access Framework (SAF) stuff.

1 Like

I have noticed that with the alpha 1.16 versions of f-droid, apps from the izzyondroid repo are not visible:

if an app is present both in the official repo and in izzyondroid it is visible from the cient and you can decide which version to install (an example is fairemail, I can see both the version of the official repo and that of izzyondroid), however if the app is only present in the izzyondroid repo it is not visible, for example if I search for aves I only see aves libre (the version of the official repo) and not the aves version of izzyondroid.

The problem seems to occur only with the izzyondroid repo (at least among the external repos I use) and no errors are reported when updating the repos.


I just tagged v1.16-alpha2, this is approaching beta quality at this point, for those who were waiting for something a bit more stable.

You can follow the work here:


I want to look into the generated v2 catalog json data to find out if it is easy to make it compatible with V1Domain · k3b/F-Droid-Universal-Catalog Wiki · GitHub

For v1 data i can download https://f-droid.org/repo/index-v1.jar and unzip the file.

Is there url where i can download a index-v2.jar or index-v2.json?
Is there any documentation for the new json file format (i.e. swagger)

https://f-droid.org/repo/index-v2.jar is not working for me.

1 Like
1 Like

Thanks a lot.

i successfully downloaded these

@k3b you might also be interested in the new download, index, and database libraries that have been split out of fdroidclient with the aim of making them easy to use in any app. They are currently maintained in fdroidclient git, with releases published to Maven Central.


you might also be interested in the new download, index, and database libraries

Exactly what i was looking for :-). I found them here libs · master · F-Droid / Client · GitLab

1 Like