Unknown error whilst updating

client
#1

Hey guys,

I am a long time user of F-Droid and never had any problems with it in the last 7 or so years. However I came across a problem I can not seem to debug myself as I do not know any Android Development. When I update my apps via F-Droid most of them do the job just fine but there seem to be always around 10-20% of my apps that are unwilling to update. Right now we speak about “Barcode Scanner”, “Delta Chat”, “Ghost Commander” and “Keepass DX”. All my other apps “Syncthing”, “AnySoftKeyboard”, “DAVx5” to name a few are up to day and did not bug out.

Trying to find the source of the problem I started a manual update (clicking on “Update” in the app view of F-Droid. It seems to download the apk and flashes me the “Do you want to install” screen. But after clicking on “Install” the progress bar is shown for a split second and returns to a error message “Failed to install due to an unknown error”.

I run F-Droid 1.5.1 on a Alcatel OneTouch Idol 3 (6039Y) with Android 6.0.1. Unfortunately I do not know how to aquire any logs from F-Droid so I would need some hint from somebody who does. However I hope you can help me with this as it is quite frustrating having a few apps that refuse to update.

Cheers

0 Likes

#2

Do you have enough space?

0 Likes

#3

Yes, according to Storage information there is 1,2GB free on my internal storage and another 5 on the SD card which I mounted as internal as well.

0 Likes

#4

If you download those APKs, do they install ok? If so, maybe you need to grab a logcat from the moment you try to install via F-Droid so we can see the error.

0 Likes

#5

How would I download the APKs? I can not find any links to them.

I have adb on my Computer so I could give you a log dump if you tell me how I filter for the relevant stuff.

0 Likes

#6

On the website, ofcourse:

https://f-droid.org/en/packages/com.b44t.messenger

Use the search field :wink:

0 Likes

#7

Well I was not on the website for so long that I did not even see that field in the first place^^

However, installing via the APK for DeltaChat fails as well with an “App not installed” message. I must say Android shines with helpful information in that regard…

0 Likes

#8

Ok, so it’s a general thing, aka your Android has some issues.

You’ll need to get an ADB log for the moment you try to install.

0 Likes

#9

Well I tried before but I do not know what to look for as I drown in log entries when I just run adb logcat. Any idea what I should filter for or flags to use?

0 Likes

#10

You could also try to install the APK with adb install to see if you get a more helpful error.

0 Likes

#11

I tried the adb install route as @Rudloff suggested but the error message was not of much help either. Afterwards I dug through adb man pages and found how to filter: Running adb logcat *:E was helpful and produced this output whilst installing via F-Droid:

02-10 10:37:34.712   245   250 E Vold    : Error creating imagefile (Permission denied)
02-10 10:37:34.712   245   250 E Vold    : ASEC image file creation failed (Permission denied)
02-10 10:37:34.713  1704  1930 E PackageHelper: Failed to create secure container smdl814658619.tmp
02-10 10:37:34.963  1631  1631 E AppDetailsActivity: install aborted with errorMessage: Failed to install due to an unknown error

Looks to me like there is some permission problem however I have no idea as to why that is since F-Droid installs most of my apps without issues. I only have problems with those four apps on my device.

However I just uninstalled and reinstalled DeltaChat and that seems to work as DeltaChat is now v0.100.0. I did this for all the other apps as well and the problem is gone for now but I think there might still be some issue since that problem came up in the first place.

Nonetheless thank you guys for your help and suggestions.

0 Likes

#12

You could try to update one of those Apps by picking a newer version from the list of available versions. That can be viewed at the bottom of every Apps details page.

0 Likes

#13

I did that but it led to the same problem. I fixed it for now by uninstalling and reinstalling all apps that had this problem.

0 Likes

closed #14

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

0 Likes

Mastodon