Unable to run startdesktop after successful termux installation

Termux completed installation and set up vnc server, server is running x display #3, termux desktop installed successfully, restart termux and enter startdesktop.
startdesktop: command not found
~/termux-desktop/termux-desktop $

I tried termux-reload-settings and swiped the termux window up and touch the icon to restart it. How can I restart termux so I can run startdesktop?

Ask the developers: Issues · termux/termux-app · GitHub

Read the wiki: Termux Wiki

I originally had the google play version on the phone. Android did an update and I could no longer have a debian desktop in vlc. I deleted both termux and the viewer and installed termux from f-droid and followed the termux wiki directions exactly. This is verbatum from the phone:
[] Termux installed successfully
[
] Restart termux and enter startdesktop command to start the vnc server.
[*] In vnc client, enter 127.0.0.1:5901 as address and password you created to connect.

~/termux-desktop/termux-desktop $ startdesktop
startdesktop: command not found

From the above information, can someone explain how to restart termux and why startdesktop is not found?

Thank you for responding

Problem solved by doing a forced shutdown. Then I started up termux. VNC server was started with startdesktop command. Open vnc viewer, enter local host 127.0.0.1:5904 with port number, enter password, launch vnc and linux desk top appeared in viewer.

1 Like