Trying to add NewPipe Repo: No matching applications available

I am trying to add the NewPipe repository to get the latest versions, but I’m running into an issue adding that repo. I’m not sure if this is an F-Droid issue, a NewPipe issue, or something else.

I’m on Android 13 and F-Droid 1.19.1

I am trying to follow the instructions to add the NewPipe repo and the F-Droid instructions for adding repos.

After I scan the NewPipe repo QR code, it shows me a screen with info about the NewPipe repo (including “Included apps: 1”) and displays a button “Add Repository”. When I click the “Add Repository” button, it takes me to a search screen showing “NewPipe upstream repository” in the search bar and the message “No matching applications available” below

Going back to the Repositories screen, the NewPipe repo is listed and the toggle is set to enabled, but clicking on the listing it says “This repository has not been used yet. You need to enable it to view the apps it provides”. Toggling the enable button doesn’t seem to do anything.

I have tried removing the repo several times and re-adding it, but always with this same result.

Please let me know if you have any suggestions or if I’m running into a known bug (hopefully I’m just doing something wrong).

After it is added, give it few minutes to fetch the indexing from its repository and get ready to display details.
BTW the repo URL is: NewPipe upstream repository & the fingerprint is: E2 40 2C 78 F9 B9 7C 6C 89 E9 7D B9 14 A2 75 1F DA 1D 02 FE 20 39 CC 08 97 A4 62 BD B5 7E 75 01
Just be sure adding the correct repo.
NewPipe upstream repository

Also ensure there are no extra spaces. At times it may not be able to fetch due to that.



I re-added the NewPipe repo and waited for a few minutes on the screen with the “Add Repository” button. There is no progress indicator or anything, but just by waiting a while before pushing the button it seems to have worked as expected.

Definitely a UX issue there, but it worked.

1 Like