Trouble Using Privileged Extension on Google Pixel Running LOS

I am trying to get F-Droid working with the Privileged Extension on my Google Pixel running Lineage OS 16. Honestly, I am not really sure I am even installing the right things. I have read this thread over and over again and I think I understand most of it but the exact install process is still not really clear to me. Also, I wonder if the fact that Pixels have the whole A/B partition thing might also be complicating things for me.

What I have done:

  • Used TWRP to install LOS using adb sideload (per the official instructions)
  • Rebooted into the LOS Recovery and used adb sideload to install https://f-droid.org/packages/org.fdroid.fdroid.privileged.ota/
    • (This is the part I am not so sure of since lots of what I read about installing the PE says to use TWRP. However, my understanding is that due to the A/B setup on the Pixel I need to use the LOS Recovery to sideload things).
    • Might be worth mentioning that at the same time I am also sideloading MindTheGapps and the los suaddon and those seems to work fine.
  • Boot into LOS for the first time
  • Enable root access from the Developer Settings
  • Download and install F-Droid APK from https://f-droid.org/FDroid.apk

What Happens:

  • When I open up F-Droid and go to the settings, I do not see the expected check box for using the Privileged Extension.

Am I missing a step somewhere here? Or maybe I have installed the wrong package or something. Any suggestions would be appreciated. Thank you!

I’m using the privileged module available in the Magisk repo. Can you try that?

Might be a stupid question, but did you toggle expert mode in the F-Droid settings?

If you search for “privileged extension” in the client does it say the app is installed or not?

If it isn’t I’d try to flash via TWRP.

I didn’t toggle that, somehow it just appeared toggled ON after installing the extension.

But yeah, open expert…last option?

Thank you all so much for your help! To be clear, I had checked the Expert Mode settings and there was no checkbox for the Privileged Extension. Also I had verified that the privileged extension app in F-Droid was not marked as installed. (Should have included that in my original post).

However, I did go the Magisk route and it worked! (Had heard in passing about Magisk, but had not really looked into it before. It is awesome!)

Just to be clear in case anyone else runs into this same issue with the same setup: To install Magisk, I downloaded the zip linked from here onto a host computer and then booted my Pixel into the LOS Recovery and used the adb sideload feature to install the zip. Then I rebooted the phone into LOS and downloaded/installed the Magisk Manager app (also linked from the XDA page above). In the Magisk Manager app, I went to Downloads and searched for “F-Droid Privileged Extension” and installed that module. After rebooting the phone again, I downloaded and installed F-Droid from https://f-droid.org/FDroid.apk. Then, when I opened the app and went to the Expert settings, I could see the Privileged Extension box and it was checked! I tested it and was able to install an app though F-Droid without the extra installation dialogue.

Once again, thank you to everyone for your help!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.

Mastodon