Trouble downloading and then updating 68.0rsr

I have fdroid on my pixel XL, couldn’t download fennec. Couldn’t download it from apkpure either. Was able to install using apkmirror. After the install opened fdroid which says an update is available but that won’t work. What’s going on?

Pictures? Where did you install the first time?

Hi,
Not sure what you mean by pictures.
I don’t know if this has any thing to do with it, I have two phones. I installed fennec on the blackberry keyone Android first. Then decided it was a good app and tried to install on pixel xl also thru fdroid which I installed on pixel XL.

Why couldn’t you downwload?

Couldn’t download it from apkpure either. Was able to install using apkmirror.

Why use external sites when the APK is on f-droid.org ? https://f-droid.org/en/packages/org.mozilla.fennec_fdroid/ the first APK Version 68.3.0 (683020)

I did use fdroid, that was first thing I did, I installed fdroid on both phones, used fdroid for download, download started but in 2 seconds it stopped and acted as if it had done nothing. I even deleted the Firefox app before trying again. So I finally found apk mirror and it was only place where download worked. Then after install I opened fdroid to peek to see if fdroid could see the new fennec, it did and said there was and update, the update acted just like the bad download, started and in two seconds just stopped. So I deleted fdroid and reinstalled, then it had no update for fennec, I’m wondering if the fdroid I deleted had a glich, tonight I’ll delete fennec and see if new fdroid install downloads fennec.

Wi-Fi or mobile data? We might need some logcats when this happens.

I’m also facing same probelm with my apk. But got the solution from here.
Thanks for solving.

@Bellajohn9; Here’s what I did, I deleted fdroid app on my Android phone and reinstalled it. Also if you already have Firefox installed, fdroid might see it and think it is fennec so I deleted standard ff on my phone then went to fdroid to download. Worse case scenario I found feenec on apkmirro and it downloaded when fdroid wouldn’t.

More details please, the same what? The client? The Firefox? What issue exactly?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.