Syncthing 1.27.{0,1} won't update/install on 2x Pixel 6a

Hil all - I have syncthing 1.26.1 installed on a stock Pixel 6a, the F-Droid APK upgrades for 1.27.0 and 1.27.1 simply won’t upgrade (it visually looks like an instant crash/ignore with no error or warning dialogs). On a second stock Pixel 6a where it’s not installed, the new APKs will not install at all either. I manually downloaded them from the F-Droid website and tried outside the client app, they fail to upgrade/install at the OS layer (the APK Installer just… disappears. crashes. dunno, it’s a silent failure)

I don’t see anything in the metadata updates which looks at all suspicious or curious, the updates appear to be run of the mill version upgrade additions, e.g.: Update Syncthing to 1.27.0 (4373) (db373704) · Commits · F-Droid / Data · GitLab

I’ve searched around for other folks having this problem, open issues, etc. and am coming up empty - anyone have a clue what could be going wrong here? The server side is upgraded to 1.27.1 (Debian 12) no problem and the installed 1.26.1 app is working fine on my Pixel 6a, it just won’t upgrade the latest F-Droid build APKs. :-/

Try clearing the cache for F-Droid.

Or downloading the APK directly and installing it:


Are you saying that you can upgrade/install the APK(s) on your Android?

I overlooked that indeed.

It does look like the app ended up in a corrupted state.
Have you tried rebooting?
You may also need to uninstall it, if it doesn’t try safe mode: reboot, when you see the boot animation hold volume down until it vibrates, then once booted it should say SAFE MODE in the bottom left.


Are you saying that you can upgrade/install the APK(s) on your Android?

it updated fine for me… on 6a

Thanks for the confirmation - for the life of me I’m not able to tell why it’s crashing, and it’s the only APK with any problems. The system APK installer pops up with the usual “Install / Cancel” dialog and then… just disappears. Every other F-Droid built app installs/updates just fine, I may have to resort to ADB debugging logs at this point. :frowning:

Found the upstream issue, it is indeed a problem more people are experiencing and seems related specifically to the latest Android 14 updates and some sort of bitmap scaling issue (I’m not a programmer by trade).

The upstream issue describes everything I’m experiencing: Installing APK fails with 'java.lang.RuntimeException: Could not copy bitmap to parcel blob' · Issue #2026 · syncthing/syncthing-android · GitHub

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.