Stuck on installing- privilege extension

its about 20min am stuck with installing!

About 30min ago, i tried started reading about fdroid privi extension. Installed privi entension for rooted device. However nothing extra happend, i mean like asking for root access or something like this. It was like installing a normal apps.

I though if i tried installing a app, perhaps a pop up for root access will appear. However, it did not appeared. Only the notification i provided above…“installing”. Also i cant install it manually since in “install” button place, the writting/msg “installing” appears.

Additinally i tried using logs since i couldnt figure out what the problem was… i got the following-

just now after closing the app, the button for “install” appeared. clicking it gives+

You’ve just installed from F-Droid?

Maybe you need to flash the .ZIP via TWRP or install the Magisk module.

What device and Android version?

yes, installed from fdroid. I though about magisk flash but read its unofficial. I cant use twrp flashing…
Will try magisk module and update here

update: at first, it failed. Magisk couldnt install the zip.
then i tried fox manager and the issue resolved.
Now installation is auto.

the privelage extension might not install correctly.

maybe try remove the current priv extension and install a new one.

im usually download the fdroid privilage extension ota on computer and adb sideload the zip file via recovery. always work for me so far.