Something recently changed

So I come to you asking for your expert opinions. Genuinely. I wasn’t sure where to ask, who to ask, Hell idk what to ask exactly… This whole thing has me down a pretty deep rabbit hole and I just want my privacy back.

I have very basic knowledge of the android operating system, linux in general, and just need a second opinion.
I’ve been fighting the “initiative against people” or whatever you wanna call em, (a group of bored, less than holy crusaders) for quite some time. Idk it’s prolly just some script kiddies, might be some hacktivists, Maybe it’s Oog itself. Idk.
But … I digress

Recently something changed. Google and tcl both keep pushing OVERLY INVASIVE weird system apps, with crazy permissions, and I’ve found some sketchy looking shit ig. I’ve tried looking into some of it but I think my internet has been poisoned. Idk. I’m probably just stupid. Tbh. I hope this is not completely out of line, but I could really use your help.

I recently wiped my phone and did my best to debloat it and primarily use f-droid apps that seem legit. I think…? Before hooking back up to the internet, but as soon as I put my sim card in, the phone is updated multiple times no matter what I do.
Maybe there are just weird system apps when using f-droid?

One app is straight up called smartratswitch.
Like c’mon.
Then I seem to have 9 Plugin apps.
And quite a few random Circular cutouts I’ve never seen a system app tray like this…
Any insight is much appreciated.
Sorry for being such a noob.

Use a firewall like Netguard to block all apps, only allow the ones you want to access the internet.

1 Like

Right. Good call.

So how do I get my internet back?
I mean some sites just get dns errors, some just take forever to …never load.
Some 403 some 404.
I mean, look, I know it sounds crazy but it’s like every time I try to go to a website, first my request is filtered to only give me information I’m allowed to have? Is that even possible?

I mean, that wouldn’t be much help if his suspicions are real and he/she has a rootkit , trojan…

Pi-Hole may be of more help for monitoring.

1 Like

Have you tried routing through Tor? or a VPN?

Yeah problem is that it uploads and downloads at 1kb /sec when I try.