Some times having trouble to install apps

Hi everyone!
I’m new here, so I hope this is the correct place to ask about a problem.
This is not the first time that I had this problem, but it bothers me… I think that this is not restricted to one app.

A few days ago there was an update for VLC (3.4.0), but I can’t manage to install it. It appears that some view tries to open and then closed down right away (crash?).

My phone is Google Pixel 4a with Android 11 stock rom.

Anyone experiencing something similar?
Does anyone know if this is a problem with the repo, the f-droid app or the vlc app itself?

Until VLC 3.3.4 everything works fine.

Best regards,
Hakaishi

Report this upstream, we only package the app, any issues should be handled by them: https://code.videolan.org/videolan/vlc-android/issues

So, you mean that it should be a problem with the apk itself?

I’ll try to contact the devs upstream.

Any way, thanks for replying and the link.

It Works For Me :slightly_smiling_face: hence my redirection to upstream

Which app crashes, F-Droid or VLC?

Oh, the wording got me confused… maybe relan is right

Neither. The installation dialog crashes. I can’t install at all.

I fixed it.
I had used the AM App Manager to manage the installations. That one was the problem maker.

Do you have enough free storage space? Eg. At least 1Gb?

Not sure how much I had until now…
Right now I have 1.9GB free RAM. (Out of 6GB)

Not RAM (memory) but storage (for files).

93GB are free. It really can’t be the storage.
Either way: I solved the problem by resetting the default app for app installs. The App Manager from f-droid was causing the problems.

Good to know, maybe you’ll find time to report it to its developers.