*solved* Newpipe, liberatube, skytube all stopped working

Yesterday during the youtube purge censorship attack all newpipe, skytube and liberatube stopped working. In newpipe i can get some vids play 30sec-45sec, skytube and liberatube just dead for the pipes i tried. Iam using netguard (DNS ?) but this setup has been working for 2years and as to my knowledge nothing is changed. All google play viruses and updates is hopefully disabled (you never know what the google assholes are up to). I have tried updating newpipe, skytube and liberatube to no avail. I receive no error messages nothing, video just dont load and stats for nerds shows nothing, no video url, nothing. Am i doing something wrong or have youtube smoked all pipes ? Iam quite stupid with low patience so kindly throw me some good ideas and hints where to look.

I have just played two videos (2 minutes length) in newpipe 0.25.2 (the newest version as of writing) without any issues.

Have you tried turning off netguard for a test?

What is the “youtube purge censorship attack” you are talking about?

1 Like

I’m using NewPipe, too and I had the same problem like you (videos stopping after round about one minute without a reason). After the last update (on Sunday?) everything’s back to normal… :thinking:

1 Like

Thank you very much for quick useful replies. I had missed the update release 20230810 (25.2) and this update seems to have solved all issues with newpipe.

Some notes : there was 2 releases of 25.2 at fdroid so I went for the apk at newpipe.net. Normally when installing a newer apk of newpipe the app is updated with my userdata but this time when upgrading from 25.1 to 25.2 app “failed to install” but installed when old 25.1 was removed. So far everything seems to work as perfect as newpipe always but apparentely it was not yesterday I was messing with upgrading to 25.1. With two small children my time is floating. I have not had time looking into liberatube and skytube yet. I never use google playstore so I have no input that route. Netguard unchanged as I dont dare releasing the viruses netguard is holding back (google play services).

LibreTube is not working, just like OP described - no error message, just doesn’t play.

Ok but what wil you you do about it

I don’t know, it did not stop working because of an update, it stopped randomly. And I don’t have time nor knowledge to fix this myself. Hopefully this issue will be resolved soon. I wonder if this is problem of an app, or something else🤔

1 Like

Now I am having issues with newpipe 25.2 too. Fails BEFORE even playing and there IS an error message.

Looks like youtube is “doing things” with their API.

Reported it to the developer.


Just for the record, 0.25.2 version of Newpipe works fine for me.

I think is possible (actually very likely) that a massive venture like youtube does not roll out changes (which might break interactions with 3rd-party clients) in all arreas at once.

So just because I am currious:
Could some of you please post were you are from and whether newpipe/others work for you?

Area: Austria (middle Europe)
newpipe: broken

1 Like

I’m from Germany and since the last update, NewPipe 0.25.2 works fine on my side… :slightly_smiling_face:

Beste Grüße aus Köln!


1 Like



Newpipe 25.2 works as good as always. Youtube seems to have made several changes latest weeks and the developers of newpipe have my full respect. When the last channels I follow move to odysee/rumble I will boycott youtube. I concur with previous report here above liberatube and skytube loads but does not play and no error messages, lets await updates.

Ooh, and that reminds me, is there a player just as good as newpipe for rumble ? The rumble player is so bad Im convinced it is made to sabotage the rumble site. It would be beautiful if rumble could be added into newpipe as source, I fully understand it is not easy.

(apologies for making this thread messy, let me know if to cut and move to new thread).

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.