[SOLVED] Fdroid as system app

Hello,
I’ve installed org.fdroid.fdroid.privileged and org.fdroid.fdroid.privileged.ota_2110 . I then used TWRP to install
/data/data/org.fdroid.fdroid/ota/org.fdroid.fdroid.privileged.ota_2110.zip
If I try to update an app, it says

Error installing SkyTube
The privileged permissions have not been granted to the extension! Please create a bug report!

What ROM? Android version? Can you use Magisk and the corresponding module instead?

Lineage OS, Oneplus 3, Android 10.

Can you use Magisk and the corresponding module instead?

How do I do that? I do have Magisk installed, but not Supersu or something similar.

(uninstall whatever you have now first)

Magisk modules -> search f-droid -> install -> reboot

Magisk has it’s own SUperuser thing, BUT F-Droid does not use root, so you don’t need to enable that.

1 Like

Do you know the filepath?

Path of what?

Aren’t I supposed to enter the filepath of the F-Droid magisk module?
The magisk -> modules page looks like this:


If I click on the “+”, I get this:

Download modules…one menu entry lower

1 Like

Ok, thank you , this worked.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.