[Solved] Delta Chat crashing after upgrade to 1.40.0

I just upgraded Delta Chat to 1.40.0 using F-Droid 1.17.0. As soon as the upgrade was finished, I got a pop up telling me Delta Chat had crashed, and asking me to either wait or close app.

I restarted my device (Android 11, specifically OxygenOS 11.1.2.2 on a Samsung OnePlus) but every time I tap on the Delta Chat icon to openo the app, I get that same crash dialogue.

I checked the version info in F-Droid and there appears to be two entries for each version number, both added on the same date. Intriguingly, there appear to be no versions older than 1.36.5, added on both 5/5/23 and 10/5/23

Uodate: I tried to downgrade to 1.38.2 but I didn’t work. I still appear to have 1.40.0 and it’s still crashing on startup.

1 Like

1.40.0 also crashes for me. Older versions work though. I’ll look into it.

1 Like

Thank you for the info.

I’ll skip that update . . .

Have you opened an issue at their github page?

Yes.

You have :slight_smile:

:+1:

Thank you

This was fixed when F-Droid shipped version 1.40.1. I suggest everyone upgrade to this version ASAP (unless you have a good reason to stay on an older version).

2 Likes