[solved]Corona Contact Tracing Germany / LineageOS 18.1

Hello,
i used Corona Contact Tracing Germany on Lineage17.1 without problems. I installed Lineage18.1 (fresh install) and installed Corona Contact Tracing Germany again. Now the app is not able to use exposure notifications. Do i have to install microg? I’m not sure, if microg was installed on the previous system - i tend to say “no”. IIRC, I simply installed Corona Contact Tracing Germany and it worked.
Is Lineage18.1/Corona Contact Tracing Germany a known problem, or does it hit only me? Does anyone have a suggestion?
Thanks for porting CWA to f-droid!

“If microG is already installed on your system, it will make use of its Exposure Notifications implementation. Otherwise, it will use the bundled implementation. It will never connect to the Google Play services Exposure Notification System. You can find out which implementation is used by checking the status at the bottom of the App Information screen.”

1 Like

Hello,
thank you for your quick reply. In the App-Info window i read the following: “Version 1.15.1.0
Sie benutzen das in der App integrierte microG in Version 18204714000”.

When i try to start risc-detection i’m asked to enable Exposure Notification. A tip on “ERTEILEN” has no effect, nothing changes. I have to continue with “ABBRECHEN”.

Do you have any idea (except installing microG)?

Thanks

1 Like

I don’t have an idea :confused: Maybe it is a bug and it would be useful to open an issue in their repo…
Otherwise you could also try to use the last version they just published (2.0.3.0)

Lineage runs on an old Oneplus One, i had a look on issues on that combination. It seems that there are currently (LineageOS18.1) problems with NFC, maybe that’s the reason. I will wait until the next Lineage update, maybe that’s going to solve the problem.
Thank you for your help!

I thought CCTG uses bluetooth :thinking:

1 Like

Sorry, erroneously i classified bluetooth into NFC…
Just after my last reply there came an update on LineageOS. I installed it, and reinstalled Corona Tracing. Now everything works. I don’t know if it has to do with the update on LineageOS, i didn’t try a reinstall of Corona Tracing App before.
Thank you for your ideas!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.