Show app icon in F-Droid client


I noticed that my app lacks an icon in F-Droid client despite of having one. I compared my app to other apps and I see no particular differences:

  • I have reference to a .png image as android:icon in AndroidManifest.xml.
  • F-Droid meta data is described in a single .txt file. No reference to icon there.
  • No obvious and additional files in the app repository, i.e. no fastlane structure.

Yet, no icon. Of course, once the app is installed, it has icon in launcher. I compared several apps. One example being com.vadimfrolov.duorem.txt vs com.lucasdnd.decimaltimeclockwidget.txt.

I’ve read the docs (the one titled All_About_Descriptions_Graphics_and_Screenshots). Have not tried the fastlane structure yet since it seems like there are a lot of apps that do not use it and still have their icons visible.

Anyone knows how to show icon?


in my app I have the same/a similar issue. No icon and no feature graphic is shown in the f-droid client.
The situation here is slightly different for me, as I have the metadata in Triple-T format/file structure, which is documented as being supported.

I just realized, that after switching my language in the Android system settings to English, I see the icon but the feature graphics is still missing.

What is even more strange is, that after I switch to English (Germany), the description text stays German… (but it seems to be not robustly reproducible)
With English (US) - which is the default locale in the app, I even see the recent changes from the whatsnew file (which is localized in my app). In Triple-T and playstore everything seems to be fine, at least as expected :slight_smile:

What I recently did without knowing whether it has an effect is adding some icon png files in app/src/main/ just to try whether it helps.

Any idea help or feedback is appreciated. @fralik what is your app?


Thanks for the info!
My app is mentioned in the first post. Here it is again, called duorem.

ah, the first link was to your app. - I didn’t recognize that, but understood it as two examples. Anyhow, my answer did obviously not really help - I hope someone who is deeply involved in the f-droid-client can help us out here.

A small update. I’ve followed the recommended fastlane structure and added icon to the repo. Web-version seems to pick it. F-Droid client on my phone does not:

Although F-Droid client picked up what I believe is a feature graphic.

it is really strange, that the icons are shown on the website but not in the f-droid app. This feels like a bug to me. @hans can you explain that? Should we file a bug report?

if you think there is a bug, please file a bug report :slight_smile:

I tried to find out whether the data is correctly in the repo - to check whether it is a bug in the client app or the server, but didn’t find any docs. During browsing the code the idea to uninstall f-droidclient and reinstall it. Now I see the icon as on the webversion of ActivityDiary. For Duorem it still shows a robot icon plus the featureGraphics.

Mh, for now I think I just give up, maybe I find some motivation to dig into the repo format some time later…

Edit: after switch back and forth my language settings in Android the icon is again gone.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.