Should F-Droid client and Privileged Extension OTA be flashed at the same time?


  1. Install the F-Droid APK first?
  2. Then, flash the Privileged Extension via recovery?

Yep. The order shouldn’t matter actually.

In my first attempt, I flashed the Privileged Extension OTA first. Then, I installed the F-Droid APK.

But the Priveleged Extension option didn’t appear in F-Droid Settings. So, I tried reflashing it again, but still no dice.

Is there anything relevant in logcat?

I haven’t checked. What’s the recommended way of doing that?

1 Like

Are you on android q? i have this problem, seems like ota doesnt work on system-as-root layouts

Android 9. What does system-as-root mean?

What does system-as-root mean?

A new filesystem layout:

1 Like

Is there like an ELI5 summary? The documentation on is pretty technical.

Hi, From my experience, running LOS 16 on BQ Aquaris : I flashed the following zip that you can get from here : You need root privilege, aka installed before (for LOS).
Then once I boot up the device, F-Droid was installed, and Priviliged Exstension as well. Automatic updates for F-Droid Apps work like a charm.
Hope that helps,

1 Like

I tried this OTA at LOS 17. But it seems nothing happend in FDroid. Does it somehow request root access at Magisk (as other apps that requires root)?
Is it because Q / LOS17 isn’t supported?

No root asked.

Can you look in F-Droid Settings…expert…is the last option checked?

Hello, I’m having same isuues. I’m using crdroid 6.5, based on android Q, and flashed the privileged extension zip with TWRP, last option in fdroid expert mode is enabled.

The error message is as follow:
“The privilege permissions have not been granted to the extension! Please create a bug report.”

EDIT: Flashing the magisk module works. Perhaps it could be told in the package description as an alternative? :slight_smile:

1 Like

@relan @Licaon_Kter (@Roboe ), this can be considered as custom recovery bug: lack of mount_apex()

(but soon or later F-DroidPrivilegedExtension may (?) need hot build of patched Busybox : (as in ?

1 Like

Basically this ota zip didn’t work in android 10 roms. I think Dev’s should work on it. I tried all possible thinks but not working in all roms. In twrp recovery it says it’s flashed successfully but when I boot phone there is no app and nothing change.

Manually app installed but that ota zip is just bluff I guess. I always tap to install button always to install app from F-droid. Also there is no support from Dev’s which is worst thing in my opinion.

1 Like

Did you tried to flash the magisk module? Worked for me.


Note that you DON’T FLASH the Magisk module, you just “install it in Magisk”

1 Like

I don’t use Magisk so no. I don’t like Magisk and magisk module. I wish that they give support for this privilege ota zip.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.