Secure connection failed mull 98.2.0

i would like to know opinion first before filing an issue on mull repo.

the issue is with rediff.com. i did not created rediff mail acc on mull. i am using mull from today.

when i entered login credentials for my rediff mail it shows “secure connection failed”. i have disabled https everywhere and EPT is off.

Fennec works? Firefox from Mozilla works?

@Licaon_Kter i will test and let u know.

@Licaon_Kter tested on both
fdroid fennec 98.2.0 = no issue
mozilla firefox (github apk) = no issue
98.2.0 (Build #2015868577), 2b529a583+
AC: 98.0.12, 9ad94b2a33
GV: 98.0.1-20220313140707
AS: 91.0.1

@SkewedZeppelin ^^^

Set security.OCSP.require in about:config to false

@SkewedZeppelin its not working. perhaps ca is not capable enough.

Actually does not work even then. I even tried for a trial security.OCSP.enabled to 0, but it keeps giving the error. This happens randomly and when the same would work in Bromite or aome other app. Even let us say it worked 10 seconds earlier and all of a sudden it will throw up the error and after a force stop and cache clear it will work. Again randomly it will throw up and randomly it will start working again. I face it so many times daily with varied sites.

Edit: This is not limited to any particular build number. It keeps happening over various builds. First I faced last March-April and then frequently from September 2021.

Most browsers perform OCSP checks by default but ignore the result.
Mull makes OCSP mandatory and will not connect if the check fails.

From what I’ve seen there are two issues:

  • OCSP servers go down a lot
  • Many users use adblockers or DNS servers that wrongly block these OCSP domains

In either case result is this error.

You can use the workaround of setting security.OCSP.require in about:config to false.
You must use the Quit button to persist changes made in about:config.

1 Like

set security.OCSP.require to false. and provided login credentials on fresh installation of browser. set etp=off and did not installed any addon. deleted browser data on quit as suggested. the issue is not resolved.

the reason behind error by @SkewedZeppelin is good. and i am happy to continue using mull.

i am marking this thread as answered and hopefully there will be no more replies.