Requested file was not found ......repo/org.fdroid.fdroid_1012002.apk

After downloading the new index (?) data file, it says a new alpha is available, but can’t find it (3 devices).

Now that the f-droid repo data file is so big (depending on perspective), is there any consideration of changing to a different method? Like have a “shopping for new apps” mode and a “just update the old apps” mode. The big data file would only be downloaded again for the shopping mode. Edit: Or better, app data would be downloaded similar to app images, only as needed, on demand (streaming mode or all-at-once mode option).

A benefit would be the server could do the check for availability of the download, before telling the user (currently via the data file) that an update was available, when it’s really not yet available.

Edit2: It was only a short time of unavailability. File is now found.
Edit3: File downloaded, but install fails quietly, on one device. Other devices still see “not found”. Going away to be more patient. :smiley:
Edit4: Maybe it is a “network” issue disguised by a “not found” error message, because the “not found” error message was displayed once during mid-download. A workaround was deselecting all but one mirror in the f-droid mirror list. Lucky guessing found a mirror that worked.

1 Like

I have the same issue. This link https://f-droid.org/repo/org.fdroid.fdroid_1012002.apk works so the problem is that a mirror is broken. I disabled all mirrors and it works now.

Good afternoon:

After updating the contents of the fdroid ones. I notice on the main page of fdroid that there is a new version.

But I don’t get the notice or anything.

I try to download it but always no apk is found. And the problem is not that alone, I look at other apps and the same error.

I thought it could be a failure of my WiFi or mobile network. But everything else goes down perfectly. That is of any other application that is not fdroid. I even downloaded the latest apk from fennec from fdroid and installed it. But still with the same problem. I can’t install anything.

Clean cache, pass lte cleaner. Reboot the router. The mobile. Turn it off and on again. I cleaned all caches of all applications and nothing.

The only thing I’m missing is to delete data from fdroid. But this gives me that will erase everything I have installed. If I’m not mistaken ¿?¿?¿.

I tried on several phones and there is no way.

A hug

But I don’t get the notice or anything.

Alpha versions is not suggested so no notification.

The only thing I’m missing is to delete data from fdroid. But this gives me that will erase everything I have installed. If I’m not mistaken ¿?¿?¿.

Only F-Droid will be clear.

If you can download apks from the website, then I guess a mirror is broken. Disable all mirrors and try again.

1 Like

They are if you Hit Settings, advanced, unstable updates.

1 Like

Good evening:

Remove all repos. Without turning off the mobile for fear of losing things. And clear fdroid cache.
Then connect to wifi, I update all things from repos. I tried to downgrade fdroid version but it gave error.

I tried many times to download and nothing.
Sometimes it downloaded some things. Others I put such a thing was not found the apk in the source. And so a lot of times.

After one time I downloaded simple music, but it didn’t appear in fdroid installed but in the application drawer of the mobile.

I removed it but it still came up in fdroid as installed. I restarted the phone and it disappeared from fdroid installed.

I tried again with tutanota. Error does not exist apk. From the search engine fdroid install something else, and uninstall it from fdroid installed applications. Which I never do and never had problems.

Then from the browser install xprivacylua. I installed it and downloaded perfectly.

It seems to fail on the main page of fdroid. And with some apk.

I will wait for the next time I update repos. Because today it does not update more.

Haber if it remains the same. And also to update fdroid to have if I dega install it.

Because from the application itself fdroid not let me outdated. Error followed. By apk could not be installed. I was doing it to return to the stable.

The previous beta I installed it because it came out in sugeridad and as an update to install.
If I know I do not install it :frowning:

Haber still doing and how it behaves. Because I would already annoy me to have to back things up and reinstall fdroid. With applications.

A hug

“APK not found” usually means that the index was already updated while the APKs are not yet there. Kind of annoying as the error message is very unspecific (and only a toast message).
Happens every now and then.
Waiting usually solves the issue after some time.

1 Like

Sounds like a known, ignored bug in the update rollout process.

Waiting usually solves the issue after some time.

A problem ignored is a problem solved. :confused:

1 Like

Does not seem to be a high priority.
Same effect for an outdated index: https://gitlab.com/fdroid/fdroidclient/-/issues/2088

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.