Repomaker doesnt start on Ubuntu

Hi, I am on latest version Kubuntu with X11-Server.

I installed the Repomaker from Flatpak (Version from 07.10.20 is the only one available), but when starting it, the icon appears in the taskbar and vanishes again. It cant start.

When starting it from the Terminal, I get
Error: runtime/org.gnome.Sdk/x86_64/3.36 is not installed

I have installed the Flatpak org.gnome.sdk Version 3.38 from Discover, but it doesnt solve it. Can I somehow install an older version?
sudo apt install org.gnome.Sdk=3.36 didnt work

Operating System: Kubuntu 21.10
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.13.0-27-generic (64-bit)
Graphics Platform: X11

How old is that flatpak?

Which Kubuntu?

added it. Pretty old, weird. Can I download it from some other site?

You can’t run fdroidserver any other way?

Note: https://gitlab.com/fdroid/repomaker/-/issues/234

I have installed on my both mint (18.3 + 20.3) pc via Software repo. Install works fine, but repomanger isn’t starting. No message, nothing.

on Ubuntu 20 I have used the tutorial on Gitlab, but same result, App isn’t starting.

How can I solve the issue ?

Which version is that? It’s a Flatpak?

try this:

flatpak run --runtime=org.gnome.Sdk org.fdroid.Repomaker

Okay this was a KDE problem for me, as I didnt have the correct or any Gnome runtime installed.

You need an older version of the Gnome runtime, I think 3.36 or something? You can install that with

sudo apt install org.gnome.Sdk=<VERSIONNUMBER>

haven’t worked
ich@ich:~$ flatpak run --runtime=org.gnome.Sdk org.fdroid.Repomaker
Fehler: runtime/org.gnome.Sdk/x86_64/3.36 ist nicht installiert
ich@ich:~$ sudo apt install org.gnome.Sdk=3.36
[sudo] Passwort für ich:
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
E: Paket org.gnome.Sdk kann nicht gefunden werden.
E: Mittels des Musters »org.gnome.Sdk« konnte kein Paket gefunden werden.

I thought a flatpak is including all needed stuff ?!?!?!

OK, i have found the issue. the trick was
flatpak install gnome org.gnome.Sdk 3.36

now repo manager is starting. Terminal is showing a lot of missing things, but it seems working

I think you need 3.36.6 Sdk. Repomaker isnt well managed and dependend on a lot of outdated packages.

I’m using that sdk

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.