Proton Pass doesn't launch

Proton Pass was finally added today, too bad that it doesn’t launch on my GrapheneOS device. I guess I will have to wait another 3-6 days :frowning:

There is no issue with builds from other sources.

I can reproduce this problem on LineageOS.

On what phone and OS was this tested before merging?

I can reproduce on Funtouch OS A13, Vivo phone, and on LOS 21 A14, OP5, as well as on A10 LG Wing, and finally on A12 OP7T.
None of the 4 phones could launch and gave runtime error. Logs are not generated at all.

Proton Pass 1.20.3

It’s not tested. The merged version is 1.20.2 and the broken version is 1.20.3 which is updated automatically.

1 Like

upstream is aware: New App: Proton Pass (!14773) · Merge requests · F-Droid / Data · GitLab

1 Like

Is there a way to publish a fixed release faster in these kinds of situations? Or will I have to wait for 1-2 cycles for the fix?

Upstream did not fix it yet, so there’s no timeline unfortunately

In these kinds of situations, does the updates come in the same way the normal updates come or is there a faster way to provide a fixed build?

Same, given that this is even the first release, it’s more about waiting a few more days.

I think it would be beneficial to have some kind of emergency protocol to release the new build as fast as possible if one or both of the following are true:

  • The app is completely unusable.

  • There is a high-severity or critical-severity vulnerability in the app.

There are at times, yes, but very rare, as all the apps will suddenly want “special privilege”

I fail to see the urgency here :person_shrugging:

1 Like

Moreover ProtonPass themselves have not fixed it, so even if there is any of quick release logic present, it will still not resolve the issue.
Also, there are other passkeep applications, and if you do need proton one, use the web browser for now. Otherwise try KeePassXC and few other foss ones here.